Genel Excel Sorusu Sor

Excel'in ön yüzü ile ilgili sorularınızı buradan sorabilirsiniz.

Excel Formül Sorusu Sor

Excel formülleri ile ilgili sorularınızı buradan sorabilirsiniz.

Excel Makro Sorusu Sor

Excel makroları ile ilgili sorularınızı buradan sorabilirsiniz.
  • 1 Mayıs 2022 tarihinden önce sitemizde kayıtlı bir üyeliğiniz varsa, yeni sistemine giriş yapmak için PAROLAMI UNUTTUM kısmına tıklayıp, e-posta adresinize gelen bağlantıyı kullanarak yeni parola belirlemeniz gerekmektedir.

Çözüldü Dikey Tabloyu Yatay Çevirme Powerquery Formülü

Mehmet

Forum Yöneticisi
Yönetici
Katılım
6 Haz 2021
Puan
4,510
Merhaba @Qene,

Excel 365 yada 2021 Versiyonu için,
D2 e bu formül dökülmeli gelir.
Kod:
=BENZERSİZ(A2:A11)

E2 ye bu formülü yazıp aşağı sürükleyin.
Kod:
=DEVRİK_DÖNÜŞÜM(FİLTRE(B$2:B$11;D2=A$2:A$11))

Daha Eski Versiyonlar için de,
D2 e bu formülü yazıp aşağı sürükleyin.
Kod:
=EĞERHATA(İNDİS($A$2:$A$11;KAÇINCI(0;İNDİS(EĞERSAY($D$1:D1;$A$2:$A$11);0;0);0));"")

E2 ye bu formülü yazıp sağa ve aşağı sürükleyin.
Kod:
=EĞERHATA(İNDİS($B$2:$B$11;TOPLAMA(15;6;SATIR($B$2:$B$11)/($A$2:$A$11=$D2)-1;SÜTUN(A1)));"")
 

MESKO

Normal Üye
Katılım
28 Tem 2022
Puan
1,927
Merhaba @Qene,

Excel 365 yada 2021 Versiyonu için,
D2 e bu formül dökülmeli gelir.
Kod:
=BENZERSİZ(A2:A11)

E2 ye bu formülü yazıp aşağı sürükleyin.
Kod:
=DEVRİK_DÖNÜŞÜM(FİLTRE(B$2:B$11;D2=A$2:A$11))

Daha Eski Versiyonlar için de,
D2 e bu formülü yazıp aşağı sürükleyin.
Kod:
=EĞERHATA(İNDİS($A$2:$A$11;KAÇINCI(0;İNDİS(EĞERSAY($D$1:D1;$A$2:$A$11);0;0);0));"")

E2 ye bu formülü yazıp sağa ve aşağı sürükleyin.
Kod:
=EĞERHATA(İNDİS($B$2:$B$11;TOPLAMA(15;6;SATIR($B$2:$B$11)/($A$2:$A$11=$D2)-1;SÜTUN(A1)));"")
Makro ile nasıl yapılabilir. Mümkünse ADO , SQL vs. ile

Teşekkürler.
 

Mehmet

Forum Yöneticisi
Yönetici
Katılım
6 Haz 2021
Puan
4,510
@KMLZDMR eski versiyon DİZİ alternatifleri Ctrl + Shift + Enter gerektirir. Dizi formülleri pek tavsiye etmem ama hem çalışma kitabını daha da yavaşlatırlar. Hem sütun ortasından(kısmi) formül değişikliği yapılamaz tüm formüllerin değişimini gerektirir.

D2 için aşağı sürüklenecek.
Kod:
=EĞERHATA(İNDİS($A$2:$A$11;KAÇINCI(0;EĞERSAY($D$1:D1;$A$2:$A$11);0));"")

E2 için sağa ve aşağı sürüklenecek.
Kod:
=EĞERHATA(İNDİS($B$2:$B$11;KÜÇÜK(EĞER($D2=$A$2:$A$11;SATIR($B$2:$B$11)-1);SÜTUN(A1)));"")
 

Ali Kırksekiz

Forum Yöneticisi
Yönetici
Katılım
28 Tem 2022
Puan
10,627
Ofis 365 daha kullanışlı çalışıyor olsam Mehmet Bey'in formüllerini tercih ederdim. Eski versiyonlarda Mehmet Bey'in formülleri daha etkin onda da onun verdiğini kullanırdım .Ben sadece çeşitlilik olsun adına farklı formül ekliyorum.
 

Ekli dosyalar

  • Formüller ile devrik dönüşüm.xlsx
    35.4 KB · Görüntüleme: 5

Burhan.cesur

Forum Yöneticisi
Yönetici
Katılım
28 Tem 2022
Puan
10,849

kmlzdmr

VIP 4
Katılım
22 May 2019
Puan
1,095
@KMLZDMR eski versiyon DİZİ alternatifleri Ctrl + Shift + Enter gerektirir. Dizi formülleri pek tavsiye etmem ama hem çalışma kitabını daha da yavaşlatırlar. Hem sütun ortasından(kısmi) formül değişikliği yapılamaz tüm formüllerin değişimini gerektirir.

D2 için aşağı sürüklenecek.
Kod:
=EĞERHATA(İNDİS($A$2:$A$11;KAÇINCI(0;EĞERSAY($D$1:D1;$A$2:$A$11);0));"")

E2 için sağa ve aşağı sürüklenecek.
Kod:
=EĞERHATA(İNDİS($B$2:$B$11;KÜÇÜK(EĞER($D2=$A$2:$A$11;SATIR($B$2:$B$11)-1);SÜTUN(A1)));"")
Teşekkür ederim.
 

52779

Forum Yöneticisi
Yönetici
Katılım
30 Mar 2019
Puan
8,868
Selamlar,

Ben listeyi biraz farklı ele aldım.
Listede, tekrar edenler ve BOŞ hücreler de var.

1650648581538.png

Çözümler Excel 365... (Beta kanalındaki Yeni işlevler de kullanıldı ve LAMBDA nın yardımcı işlevlerinden MAP, MAKEARRAY, SCAN da kullanıldı)

İlk çözümlerde, Benzersiz isimler dökülmeli gelir. Ancak, Dersler, kendi satırlarında dökülmeli olup, aşağıya doğru kopyalanmalıdır.
Sağdaki çözümlerde ise,
Komple dökülmeli olarak çözümler yer almaktadır.

Dosya ektedir...
 

Ekli dosyalar

  • Ogr_Ders_Devrik_365.xlsx
    15.3 KB · Görüntüleme: 5
Moderatörün son düzenlenenleri:

Burhan.cesur

Forum Yöneticisi
Yönetici
Katılım
28 Tem 2022
Puan
10,849
Her türlü çözümler sunulmuş formüller makro power query. Zaman ayırıp Çözüm veren tüm hocalarıma ayrı ayrı çok teşekkür ederim. @Burhan.cesur hocam Power Query ile çözüm metodunuzu GİF ile açıklama yaparsanız çok sevinirim. Teşekkürler şimdiden.
@Qene İlgili görsel ektedir.
2022-04-22-20-35-13.gif
 
Moderatörün son düzenlenenleri:
Katılım
31 Ara 2019
Puan
513

Hazır Excel Dosyası İndir

İki Tarih Arasındaki Hafta Tatili Sayısını Bulma işlemi öğretilmektedir.
5.00 Oylama 1 İnceleme
İndirilme
4
Güncelleme
  • Öne çıkan
Formüller ile Yıllık İzin Takip Çizelgesi işlemleri yerine getirilmektedir.
5.00 Oylama 2 İnceleme
İndirilme
39
Güncelleme
Yıllık İzin Talep Formu ile çalışanlarınızın izin taleplerini oluşturabilirsiniz.
5.00 Oylama 2 İnceleme
İndirilme
6
Güncelleme
Her X Sütundaki Değerleri Toplama işlemi öğretilmektedir.
5.00 Oylama 1 İnceleme
İndirilme
8
Güncelleme
En Yakın Lokasyonu ve Uzaklığını Bulma işlemi öğretilmektedir.
5.00 Oylama 1 İnceleme
İndirilme
7
Güncelleme

Benzer İçerikler

Cevaplar
7
Görüntüleme
1K
Üst
Konuşma Başlat
Sitemiz ile ilgili tüm soru(n)larınız için hızlı iletişim kurabilirsiniz. Excel sorularınız cevaplanmayacaktır.
Ekip üyelerimizden ilk müsait olan cevap verecektir.