Mutlaka Bilinmesi Gereken Excel Formülleri içeriği, en çok kullanılan fonksiyonlara dair örnekler ve bilgilendirici açıklamalardan oluşmaktadır.

ALTTOPLAMSUBTOTAL=ALTTOPLAM(4;B3:B13)B3:B13 hücre aralığındaki sayısal değerlerin en büyüğünü yazdırmaya yarar. Formül içinde geçen 4 rakamı, MAK fonksiyonun işlevini döndürmeyi sağlamaktadır. Bu rakamları değiştirdikçe, B3:B13 aralığındaki sayısal değerlere farklı matematiksel işlemler yapacaktır.
ARALOOKUP=ARA(B13;A4:A10;B4:B10)B13 hücresinde 65 değeri yazılıdır. A4:A10 aralığında 7 satırlık not baremleri, B4:B10 aralığında da notlara karşılık açıklamalar yazılıdır. Formül, 65 değerine denk gelen açıklamayı yazdırmayı sağlamaktadır. ARA fonksiyonu bu gibi çok fazla ihtiyaca çözüm olmak için kullanılabilir.
ARALIKBİRLEŞTİRCONCAT=ARALIKBİRLEŞTİR(B5;C5;D5)B5, C5, D5 hücrelerindeki değerleri birleştirerek aynı hücrede yazmanızı sağlar.
AŞAĞIYUVARLAROUNDDOWN=AŞAĞIYUVARLA(B3;B4)B3 hücresinde 12345,123456789 yazılıdır. B4 hücresinde ise 0 yazılıdır. Formül, 12345 sonucunu yazdıracaktır.
AYMONTH=AY(BUGÜN())Formül, bugüne ait tarih AY numarasını yazdıracaktır.
BAĞ_DEĞ_DOLU_SAYCOUNTA=BAĞ_DEĞ_DOLU_SAY(B4:B12)B4:B12 hücre aralığında ne yazılıysa, dolu olarak sayacaktır. Formül sonuçları, hatalar vs her şeyi saymaktadır. Eğer hücre boşsa, o zaman saymayacaktır.
BAĞ_DEĞ_SAYCOUNT=BAĞ_DEĞ_SAY(B4:B12)B4:B12 aralığında bulunan sadece sayısal nitelikteki değerleri sayar. Formül hataları ve metin değerleri sayıya dahil etmez.
BİRLEŞTİRCONCATENATE=BİRLEŞTİR(B3;" ";B4)B3 hücresinde "Excel", B4 hücresinde "Depo" yazılıdır. Formül, "Excel Depo" olarak yazdırılmasını sağlamaktadır.
BOŞLUKSAYCOUNTBLANK=BOŞLUKSAY(B4:B12)B4:B12 hücre aralığındaki boş hücrelerin sayısını vermektedir.
BUGÜNTODAY=BUGÜN()Günün tarihini veren formüldür. Formül sonucuna bağlı olarak nasıl görünmesini isterseniz, Hücre Biçimlendir özelliğini kullanabilirsiniz.
BULFIND=BUL("Depo";B3)B3 hücresinde, Excel Depo yazmaktadır. Formülümüz, için "Depo" kelimesi arandığından, bu kelimenin ilk harfinin başladığı sıra numarası olan 7 sonucunun döndürecektir.
BÜYÜKLARGE=BÜYÜK(B4:B11;1)B4:B11 hücre aralığında benzersiz sayılar yazılmıştır. Formülümüz, bu sayılardan en büyük olanını yazdıracaktır.
BÜYÜKHARFUPPER=BÜYÜKHARF(B3)B3 hücresinde yazılı olan tüm cümleyi, tamamı büyük harfle yazılı hale getirmektedir.
ÇEVİRCONVERT=ÇEVİR(B3;B4;B5)B3 hücresinde: 70, B4 hücresinde: mph, B5 hücresinde: km/hr yazılıdır. Formülümüz, bu verileri kullanarak sonucu 112,65408000 şeklinde döndürecektir.
ÇİFTMİISEVEN=ÇİFTMİ(B3)B3 hücresinde 27 yazılıdır. Formülümüz, "YANLIŞ" sonucunu döndürecektir.
ÇOKEĞERIFS=ÇOKEĞER(C3<60;"E";C3<70;"D";C3<80;"C";C3<90;"B";C3>=90;"A")C3 hücresinde öğrencinin aldığı not yazılıdır. Formül, notun 5 ayrı sayı grubuna göre hangi harfe geldiğini bulmaya yaramaktadır.
ÇOKEĞERMAKMAXIFS=ÇOKEĞERMAK(D3:D12;C3:C12;"Kadın")Cinsiyet ve Not şeklinde iki sütundaki veriler vardır. Formül, cinsiyeti "Kadın" olanlardan en yüksek notu döndürmektedir.
ÇOKEĞERMİNMINIFS=ÇOKEĞERMİN(D3:D12;C3:C12;"Kadın")Cinsiyet ve Not şeklinde iki sütundaki veriler vardır. Formül, cinsiyeti "Kadın" olanlardan en düşük notu döndürmektedir.
ÇOKEĞERORTALAMAAVERAGEIFS=ÇOKEĞERORTALAMA(D3:D12;C3:C12;"Kadın")Cinsiyet ve Not şeklinde iki sütundaki veriler vardır. Formül, cinsiyeti "Kadın" olanların not ortalamasını yazdırmaktadır.
ÇOKEĞERSAYCOUNTIFS=ÇOKEĞERSAY(D3:D12;">50";C3:C12;"Kadın")Cinsiyet ve Not şeklinde iki sütundaki veriler vardır. Formül, cinsiyeti "Kadın" olup, notu 50'den yüksek olanların adetini yazdırmaktadır.
ÇOKETOPLASUMIFS=ÇOKETOPLA(D3:D12;C3:C12;"Kadın")Cinsiyet ve Not şeklinde iki sütundaki veriler vardır. Formül, cinsiyeti "Kadın" olanların notlarının toplamını yazdırmaktadır.
DAKİKAMINUTE=DAKİKA(ŞİMDİ())Formül, anın saatindeki dakika sonucunu döndürecektir.
DAMGACHAR=DAMGA(B3)B3 hücresinde 38 yazılıdır. Formül, 38 yazısında denk gelen simge olan & şeklini yazdıracaktır.
DEĞİLNOT=DEĞİL(EBOŞSA(B3))B3 hücresinde 65 yazılıdır. Yani bir değer olduğundan dolayı, formül sonuç olarak DOĞRU döndürecektir. Tek başına bir işe yaramaz. Bir mantıksal formüle göre DOĞRU ya da YANLIŞ sonucunu döndürür.
DEĞİŞTİRREPLACE=DEĞİŞTİR(B3;6;1;"#")B3 hücresinde "Excel Depo" yazılıdır. Formül, "Excel#Depo" sonucunu döndürecektir.
DEVRİK_DÖNÜŞÜMTRANSPOSE=DEVRİK_DÖNÜŞÜM(B3:D3)B3:D3 aralığında, 1,2,3 sayıları yazmaktadır. Formül, bu sayıları alt alta 3 hücreye yazdıracaktır.
DOLAYLIINDIRECT=DOLAYLI(A4)A4 hücresinde B4 yazılıdır. Formül B4 hücresindeki değeri bularak oradaki yazılı olan neyse onu döndürmektedir.
DÜŞEYARAVLOOKUP=DÜŞEYARA(B9;A3:B7;2;YANLIŞ)A3:B7 aralığında isim ve rakamlar yazılıdır. B9 isminde yazılı olan isme karşılık gelen sayısal rakam döndürülmektedir.
EBOŞSAISBLANK=EBOŞSA(B3)Formül, B3 hücresinde bir şeyler yazılıysa YANLIŞ, bir şeyler yazılı değilse DOĞRU sonucunu döndürecektir.
EFORMÜLSEISFORMULA=EFORMÜLSE(B3)B3 hücresindeki değer formülse DOĞRU, formül dışında herhangi bir değer ise YANLIŞ sonucu döndürülecektir.
EĞERIF=EĞER(B3>=0;"Negatif Değil";"Negatif")B3 hücresindeki değer 0'dan küçükse "Negatif", değilse "Negatif Değil" yazacaktır.
EĞERHATAIFERROR=EĞERHATA(C3/B3;"")B3/C3 sonucu bir hata döndürürse, formül herhangi bir şey yazmayıp boş sonucu döndürecektir.
EĞERORTALAMAAVERAGEIF=EĞERORTALAMA(B3:B6;">=0")B3:B6 aralığındaki değerlerden, 0'dan büyük ve eşitse olanların ortalamasını yazacaktır. Negatif sayılar varsa, ortalamaya dahil edilmeyecektir.
EĞERSAYCOUNTIF=EĞERSAY(A4:A12;"<0")A4:A12 aralığındaki 0'dan küçük sayıların adetini yazdıracaktır.
EĞERYOKSAIFNA=EĞERYOKSA(B3;"Belirtilmemiş")B3 hücresindeki formül sonucu #YOK hatası döndürmektedir. Bu nedenle formülümüz, "Belirtilmemiş" sonucunu döndürecektir.
EHATAISERR=EHATA(B5)B5 hücresindeki formül sonucu #SAYI/0! hatası döndürmektedir. Bu nedenle formülümüz DOĞRU sonucunu döndürecektir.
EHATALIYSAISERROR=EHATALIYSA(B5)B5 hücresindeki formül sonucu #SAYI/0! hatası döndürmektedir. Bu nedenle formülümüz DOĞRU sonucunu döndürecektir.
ELEMANCHOOSE=ELEMAN(B13;B4;B5;B6;B7;B8;B9;B10;B11)B13 hücresinde bir sayı yazılıdır. Formül, bu sayıya denk gelen Değer X'i yazdırmaktadır.
EMANTIKSALSAISLOGICAL=EMANTIKSALSA("DOĞRU")"DOĞRU" değerinin mantıksal bir değer olup olmadığını denetler. Sonuç : YANLIŞ
EMETİNDEĞİLSEISNONTEXT=EMETİNDEĞİLSE(F1)F1: 345 Formül F1 hücresindeki değere bakar . METİN olmadığı için sonuç DOĞRU olarak döner.
EMETİNSEISTEXT =EMETİNSE(A3)A3 hücresindeki değerin metin olup olmadığını denetler.
ENÇOK_OLANMODE =ENÇOK_OLAN(A2:A7)Aralıktaki Mod ya da yukarıda en sık tekrarlayan sayıyı getirir.
ESAYIYSAISNUMBER =ESAYIYSA(4)4'ün sayı olup olmadığını denetler. Sonuç: DOĞRU
ETARİHLİDATEDIF=ETARİHLİ(C3;C4;C5)C3 ve C4 hücrelerinde tarihler vardır. C5 hücresinde ise "d" harfi. Formül, iki tarih arasındaki toplam gün sayısını verecektir.
ETOPLASUMIF =ETOPLA(A2:A5;">160000")Formül ile A2:A5 aralığındaki 160.000'in üzerindeki değerlerin toplamı bulunur.
GÜNDAY=GÜN(A1)A1: 15.01.2024 Formül A1 hücresindeki tarihin gün değerini getirir. Sonuç: 15
HAFTANINGÜNÜWEEKDAY=HAFTANINGÜNÜ(A2)A2: 14.02.2008 Formül 1'den (Pazar) 7'ye (Cumartesi) kadar sayılarla gösterilen haftanın gününü getirir. Sonuç : 5
HAFTASAYWEEKNUM=HAFTASAY(A2)A2: 09.03.2012 Formül 09.03.2012 tarihinin yer aldığı yılda, Pazar (varsayılan) ile başlayan haftalara dayalı olarak yılın hafta numarasını getirir. Sonuç : 10
İNDİSINDEX=İNDİS(A2:B3;2;2)Formül Aralıktaki ikinci satırın ve ikinci sütunun kesişimindeki değeri getirir.
İŞGÜNÜWORKDAY=İŞGÜNÜ(A2;A3)A2: 1.10.2008, A3 : 150, Formül başlangıç tarihinden itibaren 151 işgününe ait tarihi getirir. (30.04.2009)
KAÇINCIMATCH=KAÇINCI(41,B2:B5,0)Gormül 41 değerinin B2:B5 aralığındaki konumunu getirir.
KAYDIROFFSET=KAYDIR(D3;3;-2;1;1)B6 hücresindeki değeri görüntüler
KIRPTRIM=KIRP(" İlk Çeyrek Gelirleri ")Formüldeki metnin (İlk Çeyrek Gelirleri) başındaki ve sonundaki boşlukları kaldırır.
KODCODE=KOD("A")Formül A için sayısal kodu görüntüler .Sonuç : 65
KÖPRÜHYPERLINK=KÖPRÜ("D:\MALİ\üçay1.xlsx", H10)D sürücüsünün Mali dizininde depolanan üçay1.xlsx çalışma kitabını açar ve H10 hücresinde saklanan sayısal değeri görüntüler
KÜÇÜKSMALL=KÜÇÜK(A2:A10;4)A2:A10 veri aralığındaki en küçük 4. değeri getirir.
KÜÇÜKHARFLOWER=KÜÇÜKHARF(A2)A1: Mercimek ÇORBASI. Formül metnin tamamını küçükharf olarak çevirir. Sonuç: mercimek çorbası
KYUVARLAMROUND=KYUVARLA(10,;3)Formül 10'u 3'ün en yakın katına yuvarlar. Sonuç : 9
MAKMAX=MAK(A2:A6)Formül A2:A6 aralığındaki sayıların en büyüğünü getirir.
MBULSEARCH=MBUL("p";A1;1)A1 : Excel Depo Formül A1 hücresindeki metinde ilk karakterden sonraki ilk "p" harfinin yerini verir. Formülde sonuç : 9
METİNBİRLEŞTİRTEXTJOIN=METİNBİRLEŞTİR(" ";;A1:B1)A1 : Excel, B1: Depo Formül iki kelimeyi boşluk ayracı ile tek hücrede birleştirir. Sonuç : Excel Depo
METNEÇEVİRTEXT=METNEÇEVİR(BUGÜN();"GG/AA/YY")Formül GG/AA/YY biçiminde günün tarihini getirir. 14/03/12 gibi
MİNMIN=MİN(A2:A6)Formül A2:A6 aralığındaki sayıların en küçüğünü getirir.
MODMOD=MOD(3;2)3/2'nin kalanını verir. Sonuç 1
MUTLAKABS=MUTLAK(-2)Sayı ister negatif, ister pozitif olsun pozitif olarak yazdırır. Sonuç 2 olacaktır.
ORTALAMAAVERAGE=ORTALAMA(A2:A6)A2 ile A6 arasındaki hücrelerde bulunan sayıların ortalamasını bulur.
ÖZDEŞEXACT=ÖZDEŞ(A2;B2)A2 : sözcük B2: sözcük iki hücredeki verinin eşleşip eşlemediğini kontrol eder. Sonuç : DOĞRU
ÖZETVERİALGETPIVOTDATA=ÖZETVERİAL("Satışların Toplamı2013";Pivot_Sheet!$A$39;"Directör";"Hasan")Formül, pivot tablosunda verilen kriterlere uyan sonucu döndürmektedir.
PARÇAALMID=PARÇAAL(A2;6;5)A2 Hücresinde "Gece lambası" yazılıdır. Formülümüz, "lamba" sonucunu döndürecektir.
RANKRANK=RANK(B4;$B$4:$B$10;0)B4 hücresindeki değer baz alınarak, B4:B10 aralığındaki sayılar değerlendirilecek ve B4 hücresindeki sayının sırası yazdırılacaktır.
RASTGELEARADARANDBETWEEN=RASTGELEARADA(1;100)Formül 1 ve 100 arasında rastgele bir sayı üretir.
S_SAYI_ÜRETRAND=S_SAYI_ÜRET()*100Formül 0'dan büyük veya eşit ve 100'den küçük rastgele bir sayı üretir.
SAATHOUR=SAAT(A1)A1 : 0,75 formül 24 saatin %75'ini döndürür. Sonuç :18
SAĞDANRIGHT=SAĞDAN(A2;5)A2 : Satış Fiyatı .yazılan formül ile sağdan başlayarak 5 karakter alınır. Formül sonucu : Fiyat
SANİYESECOND=SANİYE(A1)A1: 16:48:18 saat versi içinden saniye değerini alır. Formül sonucu :18
SATIRROW=SATIR(C10)Başvuru hücresinin satır numarasını verir. Sonuç :10
SATIRSAYROWS=SATIRSAY(C1:E4)Başvurudaki satır sayısını verir. Sonuç : 4
SERİAYEOMONTH=SERİAY(A2;1)A2 hücresinde yazılı olan tarihten bir ay sonra gelen, ayın son gününün tarihini yazacaktır.
SERİTARİHEDATE=SERİTARİH(A2;1)A2 hücresinde herhangi bir tarih yazdığınızda, formül tam 1 ay sonrasına ait tarihi verecektir.
SOLDANLEFT=SOLDAN(B3;3)B3 hücresinde "Excel Depo" yazılıdır. Formül, "Exc" sonucunu döndürecektir.
SÜTUNCOLUMN=SÜTUN(D10)Formül, D sütunun sırası olan 4 sonucunu döndürecektir.
SÜTUNSAYCOLUMNS=SÜTUNSAY(C1:E4)Formül, C, D, E sütunlarını sayarak 3 sonucunu döndürecektir.
ŞİMDİNOW=ŞİMDİ()Formül anı yazmaktadır. Tarih, saat şeklinde..
TABANAYUVARLAFLOOR=TABANAYUVARLA(B3;B4)B3 hücresinde 27, B4 hücresinde 5 yazılıdır. Formül, 25 sonucunun döndürecektir.
TAMİŞGÜNÜNETWORKDAYS=TAMİŞGÜNÜ(B3;B4;D3:D6)B3 ve B4 hücrelerinde iki tarih (B3 daha küçük tarih), D3:D6 aralığında ise tatil günleri yazılıdır. Formül sonucu, iki tarih arasındaki işgünü sayısını vermektedir. Tatiller düşülür.
TAMSAYIINT=TAMSAYI(B3)B3 hücresinde, -7,6 yazılıdır. Formül, -8 sonucunu döndürecektir.
TARİHDATE=TARİH(2024;1;15)Formül, 15.01.2024 sonucunu döndürecektir.
TAVANAYUVARLACEILING=TAVANAYUVARLA(2,5;1)Formül, 3 sonucunu döndürecektir.
TEKMİISODD=TEKMİ(A2)Formül, A2 hücresindeki değere göre DOĞRU ya da YANLIŞ sonucunu döndürecektir.
TEMİZCLEAN=TEMİZ(B4)B4 hücresinde, ExcelDepo yazılıdır. Formül, ExcelDepo sonucunu döndürecektir. olarak yazılan hatalı karakter temizlenecektir.
TOPLASUM=TOPLA(A2:A10)A2:A10 aralığındaki sayısal değerler toplanmaktadır.
TOPLA.ÇARPIMSUMPRODUCT=TOPLA.ÇARPIM(A4:A10;B4:B10)A4:A10 ile B4:B10 aralığında sayısal değerler yazılıdır. Formül, bu sayısal değerleri yan yana birbiriyle çarpar ve toplamlarını alır.
TOPLAMAAGGREGATE=TOPLAMA(4;3;B3:B13)B3:B13 aralığında formüller ile yazılan sonuçlar yer almaktadır. Ancak, bazı formüller, hatalı sonuçlar vermektedir. Formülümüz ise, hatalı sonuçları dikkate almayp, veri aralığının maksimum değerini bulacaktır.
UZUNLUKLEN=UZUNLUK(A1)A1 hücresinde yazılı olan her neyse, uzunluğunu verir.
VEAND=VE(A2>1;A2<100)A2 hücresi 1'den büyükse ve 100'den küçükse DOĞRU sonucunu döndürür. Kural doğru değilse, sonuç YANLIŞ Olarak döndürülecektir.
YADAOR=YADA(A2>1;A2<100)A2 hücresi 1'den büyükse ya da 100'den küçükse DOĞRU sonucunu döndürür. Kural doğru değilse, sonuç YANLIŞ Olarak döndürülecektir. Burada kriterlerden birinin uygun olması yeterli olacaktır.
YATAYARAHLOOKUP=YATAYARA(B6;A3:E4;2;YANLIŞ)B6 hücresinde bir değer yazılıdır. A3:E4 aralığında ise alt alta veriler. Formülümüz, B6 hücresindeki değeri 3. satırda arayarak hemen altındaki değeri yazdırmaktadır.
YAZIM.DÜZENİPROPER=YAZIM.DÜZENİ(A2)A2 hücresindeki yazılı olan kelimelerin ilk harflerini büyük yazacaktır.
YERİNEKOYSUBSTITUTE=YERİNEKOY(A2;"Satış";"Maliyet")A2 hücresinde "Satış" kelimesi geçiyorsa, onun yerine "Maliyet" yazdırılacaktır.
YILYEAR=YIL("11.1.2023")Formül, 2023 sonucunu döndürecektir.
YILORANYEARFRAC=YILORAN(B3;B4;B5)B3 hücresindeki tarih ile B4 hücresindeki tarih değerlerinin B5 hücresindeki Yıl sayısına olan yaklaşık sayısını verecektir. B3 ve B4'e tarih, B5'e tamsayı yazarak deneyebilirsiniz
YUKARIYUVARLAROUNDUP=YUKARIYUVARLA(B3;B4)B3 hücresinde, 12345,123454789, B4 hücresinde ise 5 yazılıdır. Formülümüz, 12345,12346 sonucunu verecektir.
YUVARLAROUND=YUVARLA(B3;B4)B3 hücresinde, 12345,123454789, B4 hücresinde ise 3 yazılıdır. Formülümüz, 12345,123 sonucunu verecektir.
ZAMANTIME=ZAMAN(B3;B4;B5)B3=21, B4=14, B5=45 yazılıdır. Formülümüz: 21:14:45 sonucunun döndürecektir.

Kullanıcılarımızın içerikten yararlanması temennisiyle.
 
DMCA.com Protection Status
Geri
Üst