VE ile YADA Formülleri ve Kullanımları


İnceleme Beğeni Favori Değerlendirme Ortalama Puan Yıldız Sayısı
175 2 0 1 5
Reklam Alanı
Türkiye'nin en popüler Excel Portalındaki içeriklerin en başında reklamınızın yayınlanmasını ister misiniz?
Reklam vermek istiyorum
Çokeğer ve Eğer fonksiyonları ile koşullu formüller yazmaya başladık. smiley

Peki;
Soru: Bir sonucun gerçekleşmesi için birden fazla koşul gerekirse ne yapmalıyız?
Cevap: Birden fazla koşul yazmamız gerekirse VE ile YADA fonksiyonunu kullanabiliriz.

* VE ile YADA formüllerinde birden fazla koşulun Doğru ya da Yanlış olduğu değerlendirilir.

VE Formülünün Yapısı

=VE(mantıksal1;[mantıksal2];[mantıksal3];…)

Ve Formülünde
  • Koşulların hepsi doğru ise sonuç olarak Doğru döndürür.
  • Koşullardan biri yanlış ise sonuç olarak Yanlış döndürür.
Örnek olarak;
image(161).png

E1 hücresindeki formül;
=VE(A1=B1;C1=D1)

Formülün anlamı: A1 hücresi, B1 hücresine eşit ve C1 hücresi D1 hücresine eşitse Doğru, değilse Yanlış olarak sonuçlanır.

Formülde verilen koşullardan;
  • İlk satırda; koşulların hepsi doğru olduğu için formül Doğru sonucunu verdi. Yani A1 B1'e, C1 de D1'e eşit olduğu için.
  • İkinci satırda, koşullardan biri yanlış olduğu için formül Yanlış sonucunu verdi. Yani A1 B1'e eşit olmadığı için.

YADA Formülünün Yapısı

=YADA(mantıksal1;[mantıksal2];[mantıksal3];…)

Yada Formülünde
  • Koşulların biri doğru ise sonucu olarak Doğru döndürür.
  • Koşulların hepsi yanlış ise sonucu olarak Yanlış döndürür.

Örnek olarak;
image(162).png

E1 hücresindeki formül;
=YADA(A1=B1;C1=D1)

Formülün anlamı: A1 hücresi, B1 hücresine eşit ya da C1 hücresi D1 hücresine eşitse Doğru, değilse Yanlış olarak sonuçlanır.

Formülde verilen koşullardan;
  • İlk satırda, koşullardan biri doğru olduğu için formül Doğru sonucunu verdi. Yani C1 de D1'e eşit olduğu için.
  • İkinci satırda, koşulların hepsi yanlış olduğu için formül Yanlış sonucunu verdi. Yani A1 B1'e ya da C1 D1'e eşit olmadığı için.

VE formülü ile YADA formülünün yapısı aynı olmakla birlikte aralarındaki fark;

Sonucun Doğru olması için
  • VE formülünde tüm koşulların Doğru olması,
  • YADA formülünde koşullardan birinin Doğru olması gerekir.
Sonucun Yanlış olması için
  • VE formülünde bir koşulun Yanlış olması,
  • YADA formülünde ise tüm koşulların yanlış olması gerekir.

Ve Fonksiyonunun Eğer Fonksiyonu İle Kullanımı
* Ve ile Yada fonksiyonu Eğer Fonksiyonunda mantıksal_sınama bölümünde kullanılırlar.

Örnek olarak;
image(164).png
Bu tabloyu Eğer Fonksiyonunda Geçti/Kaldı örneğinde kullanmıştık ve
sonucun Geçti olması için gerekli şart ise Ortalama Notunun 50’den büyük olmasıydı.

Tablomuza Kanaat Notu başlıklı yeni bir sütun ekledik ve sonuç bölümünün Geçti/Kaldı olması için yeni şartımız şu şekilde
> Sonucun Geçti olması için gerekli yeni şart; Ortalama Notu 50’den ve Kanaat Notunun da 70'den büyük olmasıdır.

F2 hücresindeki formül
=EĞER(VE(D2>50;E2>70);"Geçti";"Kaldı")
  • mantıksal_sınama: VE(D2>50;E2>70)
  • [eğer_doğruysa_değer]: “Geçti”
  • [eğer_yanlışsa_değer]: “Kaldı”
Formül nasıl çalıştı?
F2 hücresi için açıklama,
- Formülde önce VE Formülü işleme alınır.
- D2 hücresindeki değere baktı, D2=60 olarak aldı, D2>50 ifadesinde D2 yerine 60 değerini yazdı, 60>50 şeklinde,
- 60, 50’den büyük mü sorusunun cevabını sorguladı ve Doğru olarak aldı,

- E2 hücresindeki değere baktı, E2=70 olarak aldı, E2>70 ifadesinde E2 yerine 70 değerini yazdı, 70>70 şeklinde,
- 70, 70’den büyük mü sorusunun cevabını sorguladı ve Yanlış olarak aldı,
- Koşul sonucundan biri yanlış olduğu için [eğer_yanlışsa_değer] bölümündeki Kaldı sonucunu yazdı.

* D4>50 ve E4>70 olduğu için F4 hücresinde Geçti yazdı.


YADA Fonksiyonunun Eğer Fonksiyonu İle Kullanımı

Yukarıda vermiş olduğumuz tabloda şartımızı şu şekilde değiştirelim.
> Sonucun Geçti olması için gerekli yeni şart; Ortalama Notu 50’den ya da Kanaat Notunun da 70'den büyük olmasıdır.

image(166).png

F2 hücresindeki formül
=EĞER(YADA(D2>50;E2>70);"Geçti";"Kaldı")
  • mantıksal_sınama: YADA(D2>50;E2>70)
  • [eğer_doğruysa_değer]: “Geçti”
  • [eğer_yanlışsa_değer]: “Kaldı”
Formül nasıl çalıştı?
F2 hücresi için açıklama,
- Formülde önce YADA Formülü işleme alınır.
- D2 hücresindeki değere baktı, D2=60 olarak aldı, D2>50 ifadesinde D2 yerine 60 değerini yazdı, 60>50 şeklinde,
- 60, 50’den büyük mü sorusunun cevabını sorguladı ve Doğru olarak aldı,

- E2 hücresindeki değere baktı, E2=70 olarak aldı, E2>70 ifadesinde E2 yerine 70 değerini yazdı, 70>70 şeklinde,
- 70, 70’den büyük mü sorusunun cevabını sorguladı ve Yanlış olarak aldı,
- Koşul sonucundan biri doğru olduğu için [eğer_doğruysa_değer] bölümündeki Geçti sonucunu yazdı.

Bu şekilde bir sonucun gerçekleşmesi için birden fazla koşul gerekirse VE ile YADA fonksiyonlarını kullanabilirsiniz.
Faydalı olması dileği ile.
BU MAKALEDE KULLANILAN EXCEL ÖZELLİKLERİ:
VE - EĞER - ÇOKEĞER - YADA

Süper, eline sağlık olsun.
Bizi alıştırma devamını bekleriz bak :)


Bir çalışma kitabına farklı cihazlardan erişebilmek, çalışma kitabını başkalarıyla paylaşabilmek ve çalışma kitabı üzerinde işbirliği yapmak için çalışma kitabını OneDrive’a kaydedin.
Bunun için;
  1. Şerit Menü'den Dosya > Farklı Kaydet’i seçin.
    • İş veya okul için
      OneDrive - <Şirket adı> seçeneğini belirleyin.
    • Kişisel dosyalar için
      OneDrive - Bireysel’i seçin.
  2. Bir dosya adı girin ve Kaydet’i seçin.
Not: Hesabınızda oturum açmanız gerekebilir.
İLGİ ÇEKİCİ İÇERİKLER
İçerik Adı Ekleyen Tarih Tür
ÇAPRAZARA Yaklaşık Eşleşme Örneği admin 13 Nisan 2020 dosya
İki kriter arasındaki değerleri sayma admin 12 Ocak 2018 dosya
Rakam ve Yazıdan Oluşan Metni Ayırma cakarem 06 Kasım 2019 dosya
Grafik - Slopegraph 52779 15 Temmuz 2019 dosya
Aynı Sütunda Hem Başlık Hem Veri İçeren Bilgiler alikirksekiz 17 Kasım 2018 dosya
Yükleniyor...