#SAYI/0! hatası nasıl düzeltilir


İnceleme Beğeni Favori Değerlendirme Ortalama Puan Yıldız Sayısı
240 0 0 0 0
Reklam Alanı
Türkiye'nin en popüler Excel Portalındaki içeriklerin en başında reklamınızın yayınlanmasını ister misiniz?
Reklam vermek istiyorum
#SAYI/0! hatası nasıl düzeltilir isimli makalemizde, bu hatanın çözümüne dair detayları anlatacağız. Adım adım ilerleyecek bu makale serimizi takip etmeniz temennisiyle.

#SAYI/0! hatası

#SAYI/0! hatası

Bir hücrede yer alan her iki değer ya da herhangi bir tanesi sıfıra eşitse ya da hücrede herhangi bir değer yoksa, #SAYI/0! hatası ile karşılaşırsınız.

Excel formülleriniz sonucunda birşeylerin yanlış gittiğini söylediklerinden dolayı, #SAYI/0! hatası almak aslında faydalıdır.

Üstteki resimde yer alan C6 ve C7 hücrelerinde herhangi bir değer olmadığı için #SAYI/0! hatası alınmaktadır.

D7 hücresinde #SAYI/0! hatasının EĞER formülü ile gizlenmesi gerçekleştirilmiştir.

Örneğin, A1:A5 aralığının herhangi bir hücresinde yer alan #SAYI/0! hatası, bu hücrelerin toplamını almak için kullanacağınız TOPLA formülünün sonucunun da #SAYI/0! hatası çıkmasına sebep olacaktır.

#SAYI/0! hatasını önlemenin en iyi yolu, verilerin eksiksiz olduğundan emin olmaktır. Beklenmedik bir #SAYI/0! hatası görürseniz, aşağıdakileri kontrol edin:

1- Bir formül tarafından kullanılan tüm hücreler geçerli/dolu bilgiler içeriyor mu?
2- Diğer değerleri bölmek için kullanılan boş hücre var mı?
3- Bir formül tarafından başvurulan hücrelerde #SAYI/0! hatası var mı?

Not: Bir sayıyı bir metin değerine bölmeye çalışırsanız, #DEĞER! hatası alırsınız.

#SAYI/0! Hatası ve Boş Hücreler

Boş hücreler #SAYI/0! hatasının yaygın nedenlerinden bir tanesidir.

Örneğin, aşağıdaki resimde, aşağıdaki formüle kopyalanarak D sütununda saat başına miktarı hesaplıyoruz:

=B3/C3

#SAYI/0! Hatası ve Boş Hücreler

C3 hücresi boş olduğu için, Excel C3 değerini sıfır olarak değerlendirir ve formül #SAYI/0! hatası döndürür.

Ortalama Fonksiyonlarında #SAYI/0! hatası

Excel'in ortalamaları hesabı yapması için üç formülü vardır:
ORTALAMA, EĞERORTALAMA ve ÇOKEĞERORTALAMA.

Ortalamaları hesaplamak için genel formül = toplam / kaç tane şeklindedir. Kaç tane olduğu bazen sıfır olabilir.

Yalnızca metin değerleri içeren bir hücre aralığını ortalamasını almayı denerseniz, ORTALAMA formülü #SAYI/0! hatası döndürür. Çünkü ortalama işlemi sadece sayısal değerler için geçerlidir.

Ortalama Fonksiyonlarında #SAYI/0! hatası

Benzer şekilde, EĞERORTALAMA veya ÇOKEĞERORTALAMA formüllerini herhangi bir veriyle eşleşmeyen mantıksal ölçütlerle kullanmaya çalışırsanız, bu formüller #SAYI/0! hatası verir. Çünkü eşleşen kayıtların sayısı sıfırdır.

Örneğin, aşağıdaki resimde, EĞERORTALAMA formülü ile her bir renk için ortalama bir miktar hesaplamak istiyoruz:

=EĞERORTALAMA(B3:B8;E3;C3:C8)

EĞERORTALAMA Örneği

Aralıkta "Yeşil" renk olmadığından (yani "Yeşil" renkli kayıtların sayısı sıfırdır), EĞERORTALAMA #SAYI/0! hatası döndürür. Sorun gidermenin en iyi yolu, kullandığınız ölçütleri doğrulamak için elle girilen küçük bir veri örneği oluşturmaktır. Birden fazla ölçüt uyguluyorsanız, ÇOKEĞERORTALAMA formülüne adım adım olacak şekilde her seferinde yalnızca bir ölçüt ekleyin.

Örneğiniz beklendiği gibi ölçütlerle çalışmasını sağladıktan sonra gerçek verilere geçin.

EĞER Formülü ile #SAYI/0! Hatasını Yakalama

#SAYI/0! hatasını yakalamanın basit bir yoluda EĞER formülü ile gerekli değerleri kontrol etmektir. D6 hücresine aşağıdaki gibi basit bir formül yazalım:

=B6/C6 /// (C6 hücresi boştur)

Üstte gösterilen örnek formülde #SAYI/0! hatası, C6 hücre boş olduğundan dolayı görünür.

C6 hücresinin bir değeri olup olmadığını kontrol etmek ve kullanılabilir bir değer yoksa hesaplamayı iptal etmek için, EĞER formülünü aşağıdaki gibi kullanabilirsiniz:

=EĞER(C6="";"";B6/C6) //// C6 boşsa hiçbir şey göstermez

Bunu daha da genişletebilir ve YADA formülünü kullanarak hem B6 hem de C6'nın değerleri olup olmadığını kontrol edebilirsiniz:

=EĞER(YADA(B6="";C6="");"";B6/C6)

Mantığını anlamak için EĞER ve YADA Formüllerinin Birlikte Kullanımı isimli dosyamızı inceleyebilirsiniz.

EĞERHATA Formülü ile #SAYI/0! Hatasını Yakalama

#SAYI/0! hatası EĞERHATA formülü ile kolayca giderilebilir. EĞERHATA formülü herhangi bir hatayı yakalar ve alternatif bir sonuç döndürür. #SAYI/0! hatasını yakalamak için, EĞERHATA formülünü D6 hücresindeki formülün dışında şu şekilde yazın:

=EĞERHATA(B6/C6;"") //// C6 boş olduğundan, sonuç hiçbir şey göstermiyor.

Uyarı Mesajı Ekleme

#SAYI/0! hatası görmek yerine bir mesaj görmek isterseniz, EĞERHATA formülünün eğer_hatalıysa_deger işlevine bir mesaj yazmanız yeterli olacaktır. Bunu yaparken dikkat etmeniz gereken tek husus, yazacağınız hata metnin çift tırnaklar arasında olmasına dikkat etmenizdir.

Örneğin, "Lütfen günün tarihini yazın" şeklindeki hata mesajını görüntülemek için aşağıdaki gibi bir formül kullanabilirsiniz:

=EĞERHATA(B6/C6;"Lütfen günün tarihini yazın")

Bu mesaj #SAYI/0! hatası yerine görürünecektir.
BU MAKALEDE KULLANILAN EXCEL ÖZELLİKLERİ:
ORTALAMA - EĞERORTALAMA - ÇOKEĞERORTALAMA - EĞER - EĞERHATA - YADA - TOPLA - Ad Tanımla

Daha önce yorum yapılmamış!

Hücrelerimize bir rakam yazdıktan sonra, bu rakamdan sonra gelecek rakamları aşağı ya da yana doğru otomatik çoğaltmak için, Doldurma Seçeneklerini kullanabiliriz.

Örneğin, herhangi bir hücreye 1 yazıp, fareyi hücrenin sağ alt köşesine getirip, sağ tık ile sağa ya da aşağı doğru sürükledikten sonra karşımıza çıkan menüden Doldurma Serisini seçmemiz halinde, diğer sayıların otomatik olarak arttırılarak yazıldığını göreceksiniz.

ipucu19
İLGİ ÇEKİCİ İÇERİKLER
İçerik Adı Ekleyen Tarih Tür
Geometri - Üçgen - THEBAULT Teoremi-03 52779 31 Temmuz 2019 dosya
Konuşan Harfler cakarem 03 Kasım 2019 dosya
Yedi bilinmeyenli matris örneği admin 07 Aralık 2016 dosya
Nota Göre Renklendirme admin 24 Nisan 2020 dosya
Koşullu Biçimlendirme | Toplamı Belli Değere Eşit Olan Satırları Biçimlendirme cakarem 23 Eylül 2019 dosya
Yükleniyor...