R1C1 Referans Stilini Etkinleştirme

Bu kod ile R1C1 Referans Stilini Etkinleştirme işlemini çok hızlı bir şekilde gerçekleştirebilir, işlerinizde zaman tasarrufu sağlayabilirsiniz.

XD Destek İste
Sub ActivateR1C1()
If Application.ReferenceStyle = xlA1 Then
    Application.ReferenceStyle = xlR1C1
Else
    Application.ReferenceStyle = xlR1C1
End If
End Sub

Gerekli Adımlar

Kodu çalıştırmanız için aşağıdaki adımları yerine getirmeniz gerekir.

  1. Microsoft Visual Basic for Applications penceresini (Alt + F11) açın.
  2. Project - VBAProject alanının, ekranın sol tarafında görüldüğünden emin olun. Görünmüyorsa, Ctrl + R kısayolu ile hızlıca açın.
  3. Araç çubuklarından Insert -> Module yazısına tıklayın.
  4. Solunda klasör simgesi olan Modules yazısının başındaki + simgesine tıklayın.
  5. Alt kısma eklenecek gelecek olan Module(1) yazısına çift tıklayın.
  6. Üstteki kodu yapıştırın.

Kod Açıklaması

Eğer Excel formüllerinin klasik stili olan A1 stilinden sıkıldıysanız, üstteki kod ile stili R1C1 biçimine dönüştürebilirsiniz. Bu işlem sonrasında;

=EĞER(A1="Ali";"Doğru";"Yanlış") şeklinde olan formülleriniz, =EĞER(RC[-1]="Ali";"Doğru";"Yanlış") şeklinde görünecektir.

Sıkılırda eski haline gelsin diyorsanız, A1 Referans Stilini Etkinleştirme kodunu kullanmanız yeterli olur.

Etiketler

50 Farklı Hazır Makro (VBA) Kodu
Excel Üzerinden Klasör Alma Kodu
56 Koşula Kadar Biçimlendirme Yapma
Makro Etkinleştirilmeden Sayfalar Görüntülenmesin
X Sayı Atlayarak Satır Gizleme
Seçimi Yazdırma
Excel Hücresine Gitme Makrosu
Hücredeki Değer Boşsa Kayıt Gerçekleşmesin
Excel Kitabındaki Sayfa Adlarının Listelenmesi
Excel Makroları ile Klasör Arama
Tarih ve Saatten Tarihi Kaldırma
Seçili Her Satırdan Sonra Bir Satır Ekleme
Yazı Efekti Verme Kodu
Yorumları Yazdırma
Kes Kopyala ve Başka Çalışma Kitabına Yapıştır
Seçili Sütunların Sayısını Bulma
Ad Yöneticisindeki Tüm Adları Görünür Yapmak
Hücrenin Arka Plan Rengini Değiştirme
Bir Değeri Renklendirme
TextBox Nesnesine Harf Girilmesini Engelleme
Bir Dizeden Sayısal Veriler Elde Etme
Negatif Sayıları Poztif Sayıya Çevirme
Seçili Hücrenin Sütun Harfini Bulma
Sütunları Otomatik Sığdırma
Satırları Otomatik Sığdır
Excel Satır Seçme Kodu
Veri Giriş Formunu Etkinleştirme
Çalışma Sayfalarını Alfabetik Olarak Sıralama
Yanlış Yazılmış Hücreleri Vurgulama
Aktif Hücrenin Satır Numarasını Bulma
Sayfadaki Kelime ve Sayı Adetlerini Bulma
Açık Olan Tüm Excel Sayfalarını Kayıt Ederek Kapatma
Bir Aralıktaki Maksimum Değeri Renklendirme
Excel Makroları ile İşlemci Bilgilerini Bulma
Boş Hücreleri Vurgulama
Birden Çok Çalışma Sayfası Ekleme
Metin Sarmayı Kaldırma
Bir Çalışma Kitabında Kaç Sayfa Var
Tüm Çalışma Sayfalarını Tek Adımda Koruma
Açılışta Üç Kere Şifre Hakkı Vermek
Excel ile Faiz Hesaplama Kodu
Her Kapatma İşleminde Otomatik Olarak Kaydetme
İçindekiler Tablosu Oluşturma
Excel Sayfalarında Çarpım Tablosu Oluşturma
Sayıları Yeni Bir Sayıyla Çarpma
Metinden Konuşma Oluşturma
Excel Alarm Kurma
Özel Sayfaları Yazdırma
Kapanışta Sayfaların Otomatik Olarak Gizlenmesi
Excel Açılırken Otomatik İşlem Yaptırma
Boş Hücreleri Sıfırlarla Değiştirme
Üstteki alanda, Google Reklamları yerine sizin reklamınızın yayınlanmasını ister misiniz?
Reklam vermek istiyorum

Daha önce yorum yapılmamış!

Bir hücrenin tüm biçimlerini en hızlı bir şekilde başka bir hücreye uygulamanın en kısa yolu, Excel'in Biçim Boyama iconunu kullanmaktır.
Başka hücreye biçimlendimek istediğiniz ana hücreniz seçiliyken;
Excel Şerit Menü  -> Giriş -> Biçim Boyacısı simgesine tıklamanız ve sonra da biçimlendirmek istediğiniz yeni hücreye tıklamanız yeterli olacaktır.

Biçim boyacısı
Yükleniyor...