Örtük Kesişim Operatörü

Örtük kesişim operatörü, Excel'in formül diline önemli yükseltmenin dinamik dizileri desteklemesi için önemli yükseltmenin bir parçası olarak sunulmuştur. Dinamik diziler, Excel'e önemli ölçüde yeni hesaplama özelliği ve işlevselliği getirir.

Yükseltilen formül dili

Excel'in yükseltilmiş formül dili, eski dilin yerini belirtmek için @ işlecini kullandığından, eski dil bunu sessizce yaparken, hemen eski dille aynıdır. Sonuç olarak, bazı formüller açıldığında @ işareti görebilirsiniz. Bunun sebebi: Formüllerinizin her zaman sahip olduğu şekilde hesaplamaya devam etmelerini sağlamaktıır.

Örtük kesişim nedir?

Örtük kesişim mantığı tek bir değere birçok değer küçültür. Excel bunu bir formülün tek bir değer döndürmesini zorunlu tutar; çünkü bir hücre yalnızca tek bir değer içerebilir. Formülünüz tek bir değer döndürmüyse, örtük kesişim hiçbir şey olmadı (Bu da teknik olarak arka planda yapılmış olsa bile). Mantık aşağıdaki gibi çalışır:

  • Değer tek bir öğsem öğeyi iade edin.
  • Değer bir aralıktır, sonra da formülün bulunduğu aynı satırdaki veya sütundaki değeri döndürün.
  • Değer bir diziyse, sol üst değeri seçin.
Dinamik dizileri kullanarak, Excel artık formüllerden tek değerler döndürmeyle sınırlı değildir, bu nedenle sessiz örtük kesişim artık gerekli değildir. Eski bir formül örtük kesişmeyle ilgili olarak tetiklenebilir, dinamik dizi etkinleştirilmiş Excel, @.

Neden @ simgesi?

@ Simgesi, tablo başvurularında örtülü kesişmesi belirtmek için zaten kullanılır. Tabloda aşağıdaki formülü düşünün = [@Column1]. Burada @ formülün, [Sütun1] ' dan aynı satırdaki değeri almak için örtük kesişim kullanacağını gösterir.

@ Öğesini kaldırabilir misiniz?

Genellikle yapabilirsiniz. Bu, formülün sağındaki formülün ne olduğuna bağlıdır:

  • Tek bir değer döndürürse (en yaygın durum), @ işareti kaldırılarak hiçbir değişiklik olmayacaktır.
  • Bir Aralık veya dizi döndürürse, @ kaldırıldığında komşu hücrelere taşma olmaz.
Otomatik olarak eklenmiş bir @ ve daha sonrasını kaldırırsanız çalışma kitabını Excel'in önceki bir sürümünde açarsanız, eski bir dizi formülü (kaşlı ayraçlar {}) olarak görünecektir.

@ Öğesini eski formüllere ne zaman eklerim?

Genellikle, çok hücreli aralıkları veya dizileri döndüren işlevler, önceki Excel sürümlerinde yazıldıklarında, @ ile eklenir. Formülünüz gibi bir değişiklik olmadığına dikkat etmek önemlidir; şimdi yalnızca önceden görünmez bir kesişme noktasını görebilirsiniz. Çok hücreli aralıklar döndüren yaygın işlevler DIZIN, uzaklık ve Kullanıcı tanımlı Işlevler (UDF 'ler) içerir. Yaygın bir istisna, dizi veya aralığı kabul eden bir işlevde (örneğin, topla () veya ortalama ()) kaydırılmışlardır.

Daha fazla ayrıntı için Aralık veya dizi döndüren Excel formüllerine bakabilirsiniz.

Örnekler

Özgün formül Dinamik dizi Excel 'de göründüğü gibi Açıklama
=TOPLA(A1:A10) =TOPLA(A1:A10) Hayır, topla işlevi aralıkları veya dizileri beklediği için hiçbir örtük kesişim oluşmaz.
=A1+A2 =A1+A2 Değişiklik yok-örtük kesişim oluşmaz.
= A1: A10 = @A1: A10 Örtük kesişim gerçekleşir ve Excel formülün bulunduğu satırla ilişkili değeri döndürür.
= DIZIN (A1: A10, B1) = @INDEX (A1: A10, B1) Örtük kesişim gerçekleşebilir. İndis formülü, ikinci veya üçüncü bağımsız değişkeni 0 olduğunda bir dizi veya Aralık döndürebilir.
= OFFSET (A1: A2, 1, 1) = @OFFSET (A1: A2, 1, 1) Örtük kesişim gerçekleşebilir. Kaydır formülü, çok hücreli bir Aralık döndürebilir. Bunu yaparken örtük kesişim tetiklenir.
= MYUDF () = @MYUDF () Örtük kesişim gerçekleşebilir. Kullanıcı tanımlı fonksiyon dizi döndürebilir. Bunu yaparken, özgün formül örtük kesişim tetikleyecektir.

Yeni formüllerde @ işlecini kullanma


@ İşlecini içeren dinamik Excel'de formül yazar veya düzenlerseniz, bu formül _xlfn olarak görüntülenebilir. Excel öncesi Excel'deki SINGLE ().

Bu, karma bir formülü kaydederken gerçekleşir. Karma formül, hem dizi hesaplamasına hem de örtük kesişmeye dayanan bir formüldür; bu, dinamik olmayan dizi Excel tarafından desteklenmez. Dinamik olmayan dizi yalnızca örtük kesişim yapan desteklenen formüller veya II) dizihesaplaması.

Dinamik dizi etkinleştirildiğinde Excel "karma formül" oluşturmayı algıladığında, formülün genelinde kesişme yapan bir çeşitleme önerecektir. Örneğin, = A1:A10 + @A1:A10 girerseniz, aşağıdaki iletişim kutusunu görürsünüz:

image-20200629103259-1.png

İletişim kutusunda önerilen formülü reddetmeyi seçtiyseniz, = A1:A10 + @A1:A10 karışık formülü de kabul edilir. Daha sonra bu formülü önceki Dinamik Excel'de açarsanız, =A1:A10 + _xlfn olarak görünür. TEK (A1:A10); _xlfn olarak gösterilen karma formülde @ şeklinde görünür .

Bu formül önceki dinamik dizi tarafından değerlendirildiğinde, Excel #AD hatası döndürecektir!
BU MAKALEDE KULLANILAN EXCEL ÖZELLİKLERİ:
#Örtük Kesişim Operatörü
Üstteki alanda, Google Reklamları yerine sizin reklamınızın yayınlanmasını ister misiniz?
Reklam vermek istiyorum

Daha önce yorum yapılmamış!

Tarihleri çoğaltmanın farklı farklı yöntemleri bulunmaktadır. Herhangi bir hücreye tarih girdikten sonra, tarih değerinin üzerine tıklayıp, sağ alt köşesinden aşağı doğru çektiğinizde, tarihin arttığını görürsünüz. Burada tarih 1 gün artacak şekilde çoğaltılmaktadır.

Eğer tarihin artmasınız istemez, aynısını çoğaltmak isterseniz, bu sefer Ctrl tuşuna basılı tutarak yine hücrenin sağ alt köşesinden aşağı doğru çekebilirsiniz. Bu şekilde yaptığınızda, tarihin aynısının aşağı doldurulduğunu göreceksiniz.

Eğer tarihi varsayılan olarak 1 gün çoğaltmak değilde, ay, iş günü, yıl gibi farklı şekillerde çoğaltmak isterseniz, sağ alt köşesinden farenin sağ tuşuna basılı tutarak sürüklemek ve karşınıza çıkacak Doldurma Seçenekleri penceresinden seçeceğiniz seçenek ile istediğiniz işlemi kolayca seçebilirsiniz.

ipucu20
Yükleniyor...