Birden Fazla Kritere Göre Arama

Excel ile verilerimizi kontrol ederken en çok kullandığımız formüllerin başında Düşeyara gelir diyebiliriz. Bu formül gerçekten hayat kurtarıcı niteliktedir. Yüzbinlerce satırlık tablolarda istediğimiz verileri kolayca bulabiliriz.

Lakin tek bir kritere göre Arama yapıp, arattığımız kriterin olduğu sütunun, arayacağımız verilerin olduğu sütunun solunda olması esastır. Dolayısıyla bu kısıtlamalara bağlı olarak bu yararlı formül her zaman işimizi görmez.

Peki birden fazla kriteri kullanarak arama yapmamız gerekirse ne yapmamız gerekir?

Örneğin aşağıdaki gibi bir tablomuz olsun
km_1
Böyle bir tabloda 102000 sicil numaralı çalışanın 2017 yılının 3. ay'ına ait maaşını bulmak istiyoruz.

Düşeyara ile formül yaparsak ilk sıra bulunan veri 1. ay olacağı için formülümüzün sonucu 1.500,00 olacak, dolayısıyla da yanlış olacaktır.

Excel'de D10 hücresine aşağıdaki formülü yazarsak istediğimiz sonucu kolayca bulacağız.

TÜRKÇE
=İNDİS(E3:E5;TOPLA.ÇARPIM((KAÇINCI(D7&"@"&D8&"@"&D9;B3:B5&"@"&C3:C5&"@"&D3:D5;0))))
İNGİLİZCE
=INDEX(E3:E5;SUMPRODUCT((MATCH(D7&"@"&D8&"@"&D9;B3:B5&"@"&C3:C5&"@"&D3:D5;0))))

Yararlı olması temennisiyle...