Birden Fazla Kritere Göre Arama

Excel ile verilerimizi kontrol ederken en çok kullandığımız formüllerin başında Düşeyara gelir diyebiliriz. Bu formül gerçekten hayat kurtarıcı niteliktedir. Yüzbinlerce satırlık tablolarda istediğimiz verileri kolayca bulabiliriz.

Lakin tek bir kritere göre Arama yapıp, arattığımız kriterin olduğu sütunun, arayacağımız verilerin olduğu sütunun solunda olması esastır. Dolayısıyla bu kısıtlamalara bağlı olarak bu yararlı formül her zaman işimizi görmez.

Peki birden fazla kriteri kullanarak arama yapmamız gerekirse ne yapmamız gerekir?

Örneğin aşağıdaki gibi bir tablomuz olsun
km_1
Böyle bir tabloda 102000 sicil numaralı çalışanın 2017 yılının 3. ay'ına ait maaşını bulmak istiyoruz.

Düşeyara ile formül yaparsak ilk sıra bulunan veri 1. ay olacağı için formülümüzün sonucu 1.500,00 olacak, dolayısıyla da yanlış olacaktır.

Excel'de D10 hücresine aşağıdaki formülü yazarsak istediğimiz sonucu kolayca bulacağız.

TÜRKÇE
=İNDİS(E3:E5;TOPLA.ÇARPIM((KAÇINCI(D7&"@"&D8&"@"&D9;B3:B5&"@"&C3:C5&"@"&D3:D5;0))))
İNGİLİZCE
=INDEX(E3:E5;SUMPRODUCT((MATCH(D7&"@"&D8&"@"&D9;B3:B5&"@"&C3:C5&"@"&D3:D5;0))))

Yararlı olması temennisiyle...

Reklam

#5 | Admin - 22.05.2017 20:57:47
+1
Avatar Ömer bey, verdiğiniz alternatif formül için teşekkürler. Bu örnekte formül çalışacaktır ama aranan kriteri, sayı değilde metin yaparsak o zaman sonuç vermez. Eklediğim formülde her iki durumda da sonuca ulaşabilirsiniz.
#4 | Admin - 22.05.2017 19:21:05
Avatar Haklısınız, Türkçe halini de revize edip ekleyeceğim.
Geri bildiriminiz için teşekkürler.
#3 | atabey44 - 22.05.2017 18:10:10
+1
Avatar =ÇOKETOPLA(E3:E5;B3:B5;"="&D7;C3:C5;"="&D8;D3:D5;"="&D9)
Şeklindeki formül de aynı işi görüyor.
#2 | atabey44 - 22.05.2017 18:03:30
+1
Avatar Çok güzel ama bir de türkçe formül olarak verseniz daha iyi olacak sanırım.
#1 | androidci63 - 27.04.2017 21:26:00
+1
Avatar çok yararlı bir formül teşekkürler.
Yorum yazabilmek için üye olmanız ya da üye girişi yapmanız gerekmektedir.