Ad Soyad Ayırmak

Herkese Merhaba;
Bir Paylaşım da Ben Yapayım Dedim.

Örnek: A2 Hücresinde Yazılan Ad ve Soyadı B2'ye Adın Gelmesi C2 İse Soyadı Gelmesi için Bir Formüldür.

AD için
=EĞER(BAĞ_DEĞ_SAY(BUL(" ";A2;BUL(" ";A2)+1))>0;SOLDAN(A2;BUL(" ";A2;BUL(" ";A2)+1)-1);SOLDAN(A2;BUL(" ";A2)-1))

SOYAD İçin
=PARÇAAL(A2;UZUNLUK(B2)+2;UZUNLUK(A2)-UZUNLUK(B2))