Excel Dizi Formülleri

Excel formüllerinin yetersiz kaldığı durumlarda, Excel Dizi Excel Dizi Formülleri isimli yazımızda nasıl dizi oluşturulacağına dair bilgiler anlatılmaktadır.

Excel Dizi Formülleri

Dizi formülü; tek bir değer yerine birden çok değerde işlem gerçekleştiren, nihai sonucu, formülün nasıl oluşturulduğuna bağlı olarak bir öğe veya bir öğe dizisi olabilen, doğru çalışması için, Ctrl + Shift + Enter tuşlarına birlikte basılması gereken bir Excel özelliğidir.

Dizi Nedir?

Dizi, Excel'de birden fazla değerden oluşan bir aralık, metin ya da sayıdır. Örneğin, {1;2;3}, {"ali", "veli", "hasan"} gibi.

Dizi formüllerinin çoğu zaman anlaşılması güç olup, tam olarak işlevinin ne olduğunu anlamak biraz zordur. Ama kullanmaya başladıkça aslında ne kadar kolay ve yararlı olduğu görülür.

Excel Dizi Formülleri

Örnek olarak =YADA(C1:C5)şeklindeki dizi formülü, üst resimdeki C1:C5 aralığındaki "A" değerini arar.

Bu dizi formülünde, C1:C5 aralığındaki değerlerin oluşumu şu şekilde olacaktır:

=YADA({YANLIŞ;DOĞRU:YANLIŞ;YANLIŞ;DOĞRU})

Sonuç olarak dizide doğru değerler yer aldığı için sonucu DOĞRU olarak verecektir.

Excel Dizi Formülleri

Üst resimdeki bir veri aralığında ise, farklı bir şekilde dizi formülü kullanarak yazmış olduğumuz hayvanların isim uzunluklarını kolayca toplayabiliriz.

Bunun için: =TOPLA(UZUNLUK(E1:E5)) dememiz yeterli olacaktır.

Burada UZUNLUK formülünü dizi içinde kullandığımız için bize dizideki tüm hayvanların isimlerinin uzunluklarını verecektir ve görünüm şu şekilde olacaktır:

=TOPLA(UZUNLUK({4;5;4;6;6}))

Sonucumuzda isimlerin uzunlukların toplamı olan 25 olacaktır.

Excel fonksiyonlarının muhteşem özellikleri sayesinde bazı işlemleri birden fazla yöntem, fonksiyon ile yapabilirsiniz.

Üstte yapmış olduğumuz, ={TOPLA(UZUNLUK(B1:B5))} formülünü, Ctrl + Shift + Enter kullanmadan =TOPLA.ÇARPIM(UZUNLUK(B1:B5)) ile de yapabilirsiniz.

Excel Dizi Formülleri - Excel Özellikleri:

Dizi Dinamik Dizi Dizi Formülü Dizi Sabiti Dizi İfadesi

Etiketler

Üstteki alanda, Google Reklamları yerine sizin reklamınızın yayınlanmasını ister misiniz?
Reklam vermek istiyorum

Daha önce yorum yapılmamış!

Makale Arşivi
Bir Excel sayfası üzerinde yer alan verilerinize ekleme yapmanın farklı farklı yolları vardır. Shift tuşu ile ekleme yapmak ise çok fazla bilinmez.
Shift tuşu ile ekleme, silme yapmak için şu adımları uygulayın:
  1. Veri ekleyeceğiniz aralığı seçin. (Ekleme yapılacak son kısma kadar)



  1. Fareyi, seçili alanın bittiği hücrenin sağ alt köşesine getirin. Koyu + şeklinde olan işaretçi farklı bir hal alacaktır.



  1. Fare işaretçisi üst resimdeki gibiyken, farenin sol tuşunu basılı tutmak suretiyle, sağa, sola, aşağı doğru gittiğinizde ekleme yapacaktır.
  2. Yukarı doğru gittiğinde ise, gittiğiniz kadar hücrenin silindiği görülecektir.
Yükleniyor...