Eğer Formülü ve Kullanımı

Excel’de Eğer Formülü, kullanımı oldukça sık olan formüllerden biridir ve formül grupları içerisinde Mantıksal Grupta yer alır.

Mantıksal gruptaki formüller belirtilen koşullara göre Doğru ya da Yanlış sonucunu verirler.

Excel’de Eğer Formülünü yazmaya başlamak, programlamada “Merhaba Dünya” demek gibidir. (Bu benim düşüncem smiley)

Eğer Formülünün Yapısı

=Eğer(mantıksal_sınama;[eğer_doğruysa_değer];[eğer_yanlışsa_değer])
  • mantıksal_sınama: Koşulun yazıldığı bölümdür.
  • [eğer_doğruysa_değer]: Koşulun sonucu Doğru ise oluşacak sonuç
  • [eğer_yanlışsa_değer]: Koşulun sonucu Yanlış ise oluşacak sonuç bölümüdür.

Örnek olarak;
  • A1 hücresine 3, B1 hücresine 4
  • C1 hücresine de =EĞER(A1>B1;DOĞRU;YANLIŞ) formülünü yazalım.
Belirtilen koşul sağlanmadığı için, yani 3 rakamı 4’ten büyük olmadığı için Eğer Formülü sonuç olarak YANLIŞ gösterecek.
Eğer belirtilen koşul doğru olsaydı, sonuç DOĞRU olacaktı.

Şimdi Eğer formülünün olmazsa olmazı Geçti Kaldı için örnek verelim. smiley

Örnek olarak aşağıdaki gibi bir öğrenci grubu olsun;

image(145).png

> Her bir öğrencinin sonucunu Ortalama Notuna göre E sütununa yazdıralım.
> Sonucun Geçti olması için gerekli şart ise Ortalama Notunun 50’den büyük olmasıdır.

Formül olarak yazmadan önce; belirtilen şartı Koşul Cümlesi şeklinde yazalım. Bu şekilde formül daha kolay anlaşılacaktır.
> Eğer, Ortalama 50’den büyükse, Geçti, değilse Kaldı.

Bu cümlenin formül hali;
=EĞER(D2>50;”Geçti”;”Kaldı”)
  • mantıksal_sınama: D2>50
  • [eğer_doğruysa_değer]: “Geçti”
  • [eğer_yanlışsa_değer]: “Kaldı”

image(146).png

Formül nasıl çalıştı?
E2 hücresi için açıklama,
- Formül önce D2 hücresindeki değere baktı, D2=60 olarak aldı,
- D2>50 ifadesinde D2 yerine 60 değerini yazdı, 60>50 şeklinde,
- 60, 50’den büyük mü sorusunun cevabını sorguladı ve Doğru olarak aldı,
- Koşul sonucu doğru olduğu için [eğer_doğruysa_değer] bölümündeki Geçti sonucunu yazdı.

Bu örnekte, Koşul cümlesinde mantıksal operatörlerden büyüktür > simgesini kullandık, koşul cümlesini değiştirelim ve küçük eşittir <=operatörünü kullanalım.

> Eğer, Ortalama 50’den küçük ve eşitse, Kaldı, değilse Geçti.
Bu cümlenin formül hali;
=EĞER(D2<=50;"Kaldı";"Geçti")
  • mantıksal_sınama: D2<=50
  • [eğer_doğruysa_değer]: “Kaldı”
  • [eğer_yanlışsa_değer]: “Geçti”
image(147).png

İki koşulun yazımı farklı olsa da sonuçları aynıdır.
- İlk koşul, 50’den büyük olanları sorguladığı için, notu 50’ye eşit olan öğrenciler Kaldı.
- Soru: İkinci koşulda, Küçük Eşit koşulu yerine sadece Küçüktür operatörünü kullansaydık ne olurdu?
- Cevap: Koşul 50’den küçüklere bakacağı için 50 ye eşit olanlar Geçti olacaktı.

image(148).png

Bu nedenle 50’ye eşit olanların Kaldı olabilmesi için <= kullanılmalıdır.

Faydalı olması dileği ile.

Eğer Formülü ve Kullanımı - Excel Özellikleri:

EĞER

Etiketler

Üstteki alanda, Google Reklamları yerine sizin reklamınızın yayınlanmasını ister misiniz?
Reklam vermek istiyorum

Gerçekten iyi bir anlatım gerçekleştirilmiş. Başarılar, Ellerine sağlık

Merhabalar;
Rica ederim :) umarım faydalı olur.

Bildiğim kadarıyla ÇOKEĞER office 365 proplus versiyonunda mevcut, yanlış bir bilgi veriyor isem düzeltilmesini rica ederim.


Evet, tüm versiyonları kapsaması mümkün olmayacak aslında. Kullanıcıların bu formülleri destekleyen versiyonlara geçtikten sonra diyelim. Bu da bir 30 yılı götürür :)
Hala 2003 versiyonunu kullananlar olduğunu biliyorum.


Gerçekten de şu klasik geçti kaldı örneği sayesinde eğer formülünün benim hafızamda kendine sağlam bir yer edindiğini düşünmekteyim. :))


:) ÇOKEĞER tüm versiyonlarda kullanılmaya başladıktan sonra, EĞER formülü bir kaç sene içinde unutulur gibime geliyor. Ama çok ekmeğini yedik kendisinin :)

Mustafa bey makale içinde teşekkürler.



Makale Arşivi
Metni Kaydır

Bir Excel hücresinde, üst resimdeki gibi yazdığınız metin, hücre genişliğini aşıyorsa ve siz bu genişliği arttırmadan, yüksekliğin otomatik olarak ayarlanmasını istiyorsanız;
Hücre seçiliyken, Excel Şerit Menü -> Giriş -> Metni Kaydır simgesine tıklamanız yeterli olacaktır.

Metni Kaydır

Metni Kaydır
Yükleniyor...