EĞER

=EĞER(mantıksal_sınama; [eğer_doğruysa_değer]; [eğer_yanlışsa_değer])
=IF(logical_test; [value_if_true]; [value_if_false])

AÇIKLAMA

EĞER Fonksiyonu mantıksal bir test gerçekleştirir ve testin sonucuna bağlı olarak DOĞRU ya da YANLIŞ şeklinde iki değer döndürür.

AMAÇ

Bir duruma bağlı sonuç üretmek.

SONUÇ DEĞERİ

DOĞRU ya da YANLIŞ

SÖZDİZİMİ

=EĞER(mantıksal_sınama; [eğer_doğruysa_değer]; [eğer_yanlışsa_değer]

ARGÜMANLAR

mantıksal_sınama : DOĞRU veya YANLIŞ olarak değerlendirilebilecek bir değer veya mantıksal bir ifade.
eğer_doğruysa_değer : [Opsiyonel] mantıksal_sınama, DOĞRU olarak değerlendirildiğinde döndürülecek değer.
eğer_yanlışsa_değer : [Opsiyonel] mantıksal_sınama, YANLIŞ olarak değerlendirildiğinde döndürülecek değer.

KULLANIM

Belirli koşulları test etmek veya değerlendirmek için EĞER fonksiyonunu kullanabilirsiniz. Fonksiyon, mantıksal sınamaya vereceğiniz karara göre DOĞRU veya YANLIŞ sonucunu verecektir.

Bir tabloda, bir sınav notuna göre "GEÇTİ" veya "KALDI" olarak sonucu yazdırmak istiyoruz. Alınan not'a göre 50 ve üzeri puan alanlar için GEÇTİ, altında kalanlar için ise KALDI sonucunu yazdıracağız.
İlk hücreye yazacağımız formül:

=EĞER(F4>=50;"GEÇTİ";"KALDI")

Aynı formülü, tersine çevirerekte yazabiliriz.

=EĞER(F4<50;"KALDI";"GEÇTİ")

İÇ İÇE EĞER KULLANIMI

Daha fazla koşulu test etmek ve daha olası sonuç elde etmek için, EĞER fonksiyonunu iç içe kullanabilirsiniz.
Her bir EĞER fonksiyonun mantığının doğru olması için dikkatli bir şekilde "iç içe" yerleştirmek gerekir.

Örneğin öğrencilerin aldıkları notlara göre harflendirme yapacak olursak:

=EĞER(F4<50,"F",EĞER(F4<65,"D",EĞER(F4<75,"C",EĞER(C6<85,"B","A"))))

EĞER fonksiyonunu, 64 kez iç içe kullanabilirsiniz.

MANTIKSAL İFADELER

Operatör Anlamı Örnek
= Eşittir A1 = B1
> Büyüktür A1>B1
>= Büyük ve Eşittir A1>=B1
< Küçüktür A1
<= Küçük ve Eşittir A1<=B1
<> Eşit Değildir A1<>B1

Desteklenen Excel Versiyonu

Excel 2003 Excel 2007 Excel 2010 Excel 2013 Excel 2016 Excel 2019

Diziliş Yapısı

mantıksal_sınama eğer_doğruysa_değer eğer_yanlışsa_değer

Etiketler

EĞER Özelliğinin Kullanıldığı İçerikler

Excel Yüzde Artış Hesaplama (dosya)

Artış Yüzdesi Hesaplama (dosya)

Filtrelenmiş Sayfalarda İşlemler Yapma (dosya)

Excel İnterpolasyon Formülü (dosya)

Eşit Kenar Uzunluğunda İç İçe Çokgen (dosya)

İki Saat Arası Hesaplama (dosya)

Yıl Bazlı Ödeme Tablosu (dosya)

Benzer Numaraların Karşısındaki Değerleri Tek Hücrede Birleştirme (dosya)

Üretim Makina Duruş Takip Formu (dosya)

Boşluksuz Değerleri Tarihe Dönüştürme (makale)

Boş Hücre İçeren Listenin Formülle Alfabetik Sıralanması (dosya)

Çoklu Düşeyara (dosya)

İş Takip Çizelgesi (dosya)

Excel Formülleri ile Alfabetik Sıralama (dosya)

Benzersiz Metin Değerlerini Ölçütlü Sayma (dosya)

Aylık Aile Bütçesi (dosya)

Kısa Çalışma Ödeneği (dosya)

Fatura Numarasına Göre Ara Toplam Alma (dosya)

VE ile YADA Formülleri ve Kullanımları (makale)

Analog Saat Grafiği (dosya)

Akademik Takvim Şablonu (dosya)

Son Üç Sayısal Değerin Ortalamasını Alma (dosya)

Üçgen Kenarlarından Geçen Elips ile Carnot Teoremi (dosya)

Sayıyı Saate Çevirme (dosya)

Excelde Türkiye İl ve İlçelerinin Koordinatları (dosya)

Eğitim Katılımcı Listesini Özetleme (dosya)

Farklı Formüller ile Aynı Sonuca Ulaşmak (dosya)

İki Değer Aralığında İnterpolasyon (dosya)

Çoklu Faiz Oranlı Adat Hesaplama Tablosu (dosya)

Personel Durum Çizelgesi (program)

Excel ile Yeni Çalışan Kontrol Listesi (dosya)

Birden Fazla Eşleşmeyi Ayrı Sütunlarda Listele (dosya)

Yüzde Oranı 0 ile 100 Arasında Yazdırma (dosya)

Formülle Netten Brüte Maaş Hesaplama (program)

Aynı Koda Ait Birden Fazla Değeri Listeleme (dosya)

İç İçe Eğer (dosya)

Excel ile Yaş Hesaplama (dosya)

Haftalık Puantaj Takibi (dosya)

Koşullu Biçimlendirme ile Performans Gösterimi (dosya)

İsimlerin Baş Harflerinden Kısaltma Nasıl Oluşturulur? (sorular)

En Çok Tekrar Eden Metinleri Bulma (dosya)

Bir Sayıyı Kriter Bazlı Parçalara Bölme (dosya)

EĞER ve YADA Formüllerinin Birlikte Kullanımı (dosya)

Makina Bakım Onarım Takip Programı (dosya)

Excel Formülleri Örnekleri (dosya)

Dinamik Formüller ile Dinamik Tablolar Oluşturma (dosya)

Seçilen Aya Ait Günlerin Listelenmesi (dosya)

Kısa Çalışma Ödeneği 7 Gün Hesabı (dosya)

Birden Fazla Eşleşmeyi Ayrı Satırlarda Listele (dosya)

İzin Takip Çizelgesi Dashboard (dosya)

Üstteki alanda, Google Reklamları yerine sizin reklamınızın yayınlanmasını ister misiniz?
Reklam vermek istiyorum

Daha önce yorum yapılmamış!

Bir veri aralığınızdaki Yinelenen Değerleri vurgulamak isterseniz;
  1. Excel Şerif Menü Giriş sekmesine tıklama
  2. Koşullu Biçimlendirme simgesine tıklama
  3. Açılan listeden -> Hücre vurgulama kuralları -> Yinelenen Değerler seçmeniz yeterli olacaktır.

Yinelenen değerleri vurgulama
Yükleniyor...