EĞER

=EĞER(mantıksal_sınama; [eğer_doğruysa_değer]; [eğer_yanlışsa_değer])
=IF(logical_test; [value_if_true]; [value_if_false])



AÇIKLAMA


EĞER Fonksiyonu mantıksal bir test gerçekleştirir ve testin sonucuna bağlı olarak DOĞRU ya da YANLIŞ şeklinde iki değer döndürür.

AMAÇ


Bir duruma bağlı sonuç üretmek.

SONUÇ DEĞERİ


DOĞRU ya da YANLIŞ

SÖZDİZİMİ


=EĞER(mantıksal_sınama; [eğer_doğruysa_değer]; [eğer_yanlışsa_değer]

ARGÜMANLAR


mantıksal_sınama : DOĞRU veya YANLIŞ olarak değerlendirilebilecek bir değer veya mantıksal bir ifade.
eğer_doğruysa_değer : [Opsiyonel] mantıksal_sınama, DOĞRU olarak değerlendirildiğinde döndürülecek değer.
eğer_yanlışsa_değer : [Opsiyonel] mantıksal_sınama, YANLIŞ olarak değerlendirildiğinde döndürülecek değer.

KULLANIM


Belirli koşulları test etmek veya değerlendirmek için EĞER fonksiyonunu kullanabilirsiniz. Fonksiyon, mantıksal sınamaya vereceğiniz karara göre DOĞRU veya YANLIŞ sonucunu verecektir.

Bir tabloda, bir sınav notuna göre "GEÇTİ" veya "KALDI" olarak sonucu yazdırmak istiyoruz. Alınan not'a göre 50 ve üzeri puan alanlar için GEÇTİ, altında kalanlar için ise KALDI sonucunu yazdıracağız.
İlk hücreye yazacağımız formül:

=EĞER(F4>=50;"GEÇTİ";"KALDI")

Aynı formülü, tersine çevirerekte yazabiliriz.

=EĞER(F4<50;"KALDI";"GEÇTİ")



İÇ İÇE EĞER KULLANIMI


Daha fazla koşulu test etmek ve daha olası sonuç elde etmek için, EĞER fonksiyonunu iç içe kullanabilirsiniz.
Her bir EĞER fonksiyonun mantığının doğru olması için dikkatli bir şekilde "iç içe" yerleştirmek gerekir.

Örneğin öğrencilerin aldıkları notlara göre harflendirme yapacak olursak:

=EĞER(F4<50,"F",EĞER(F4<65,"D",EĞER(F4<75,"C",EĞER(C6<85,"B","A"))))

EĞER fonksiyonunu, 64 kez iç içe kullanabilirsiniz.

MANTIKSAL İFADELER


Operatör Anlamı Örnek
= Eşittir A1 = B1
> Büyüktür A1>B1
>= Büyük ve Eşittir A1>=B1
< Küçüktür A1
<= Küçük ve Eşittir A1<=B1
<> Eşit Değildir A1<>B1

Desteklenen Excel Versiyonu

Excel 365 Excel 2019 Excel 2016 Excel 2013 Excel 2010 Excel 2007 Excel 2003

Diziliş Yapısı

mantıksal_sınama eğer_doğruysa_değer eğer_yanlışsa_değer
#EĞER #IF
Üstteki alanda, Google Reklamları yerine sizin reklamınızın yayınlanmasını ister misiniz?
Reklam vermek istiyorum

Daha önce yorum yapılmamış!

EĞER Formülünün Kullanıldığı İçerikler Tarih İçeriğin Türü
2 Çemberin Kesişim Bölgesi Alanı 22 Temmuz 2019 dosya
MENELAUS Teoremi 25 Ağustos 2019 dosya
KREDİ Hesaplama 14 Temmuz 2019 dosya
Son Üç Sayısal Değerin Ortalamasını Alma 15 Ekim 2020 dosya
İki Tarih Arasındaki Seçilen Günlerin Listelenmesi 11 Kasım 2020 dosya
Kriter Bazlı Gelişmiş Filtreleme 26 Nisan 2020 dosya
Önceki Yıl ile Şimdiki Yılın AYNI Aylarının Karşılaştırılması 20 Mayıs 2020 dosya
Excel İnterpolasyon Formülü 22 Ocak 2020 dosya
Arctan Excel 09 Aralık 2019 dosya
Bir Listede Yer Alıyorsa Tik Atma 09 Ocak 2021 dosya
Outlook Üzerine Alarm Kur 04 Ekim 2019 dosya
Excel Aynı Satırları Birleştirme 19 Ağustos 2020 dosya
Dönemi Tarihe Çevirmek 29 Nisan 2017 dosya
Lineer İnterpolasyon Uygulamaları 29 Mart 2018 dosya
Userform ile Seçmeli Grafikler 23 Haziran 2020 dosya
Bir Listedeki Eksik Olan Sayıları Bulma 07 Aralık 2020 dosya
Excel ile Yeni Çalışan Kontrol Listesi 13 Kasım 2020 dosya
Formül Hatalarını Yok Sayma 20 Nisan 2020 dosya
Listeye Yeni Eklenen Kayıtları Bulma ve Renklendirme 02 Mayıs 2020 dosya
En Çok Tekrar Eden Metinleri Bulma 27 Haziran 2020 dosya
Ay Bazlı Ödeme Tablosu 06 Mayıs 2020 program
Cümlenin İçinden X Sıradaki Kelimenin Alınması 05 Aralık 2020 dosya
Tatil Günlerini Renklendirme 18 Haziran 2020 dosya
Kısa Çalışma Ödeneği 7 Gün Hesabı 29 Nisan 2020 dosya
Kısmi Eşleşmeleri Listeleme 16 Nisan 2020 dosya
Nakit Akış Modeli 07 Aralık 2016 dosya
Çoklu Sütundaki Verileri Sütunda Benzersiz Listeleme 06 Aralık 2020 dosya
Sıfıra Bölme Hatası 20 Aralık 2020 dosya
Excel Listeleme Formülü 19 Ağustos 2020 dosya
Alt Alta Yazılı Değerlerin, Bir Hücrede Listelenmesi 11 Mayıs 2020 dosya
Borç Alacak Yaşlandırma Raporu 20 Kasım 2019 dosya
Faiz Hesaplaması Örneği 19 Temmuz 2019 dosya
Toplanacak Değerler Sonucu Sıfırsa Boş Bırakılsın 08 Kasım 2020 dosya
Aynı Koda Ait Birden Fazla Değeri Listeleme 07 Nisan 2020 dosya
Rakamı Yazıya Çevirme 21 Ocak 2020 dosya
Kim Hangi Ayda Doğmuş 07 Aralık 2016 dosya
Çalışan İzin Takibi 20 Nisan 2019 dosya
İzin Takip Çizelgesi Dashboard 01 Temmuz 2019 dosya
Tür ve Kilosuna Göre Eşleşen Değeri Bulun 29 Nisan 2020 sorular
Birden Fazla Değeri Aynı Hücrede Benzersiz Birleştirme 11 Ağustos 2020 dosya
Eğer Formülü ve Kullanımı 12 Temmuz 2020 makale
Ay Bazlı En Çok Satışlar ve Satıcılar 20 Haziran 2020 dosya
Alt Alta Verileri Formülle Yan Yana Getirme 14 Kasım 2019 dosya
Yılın Artık Yıl Olup Olmadığının Bulunması 08 Haziran 2020 sorular
Birleşik İsimleri Ayırma 07 Aralık 2016 dosya
Yıllık İzin Çizelgesi 26 Aralık 2019 dosya
Apartman Aidat Çizelgesi 10 Aralık 2019 dosya
Benzersiz Adetleri ve Benzersizlerin Listelenmesi 15 Temmuz 2020 dosya
Excel Yüzde Artış Hesaplama 10 Aralık 2019 dosya
Kriter Bazlı Rastgele Grup Oluşturma 20 Kasım 2020 dosya

#SAYI/0! (#DIV /0!) Hatası

Kurmuş olduğunuz formül ya bir sayıyı sıfıra bölmeye çalışıyor ya da bölme işlemini yapmak için gösterdiğiniz hedef hücrenin içeriği boşttur.

Bu hatayla ilgili daha fazla bilgi için buraya tıklayabilirsiniz.
Yükleniyor...