Bir aralıktaki benzer metinleri bir kez saymak

Bir aralığa girilmiş olan birden fazla benzer ismi, sadece bir kez saymanız gerekirse, sonuca alternatif birkaç yöntem ve formül ile ulaşabilirsiniz.


benzersiz	.png

Kullanılacak Formüller:


TOPLA.ÇARPIM (NETWORKDAYS)
SIKLIK (FREQUENCY)
KAÇINCI (MATCH)
SATIR (ROW)

Açıklama:


Üst resimde göreceğimiz şekilde bir tablomuz olsun. Bu tablodaki isimleri alternatik iki formülle sayalım:

Kullanımı:


Alternatif 1
Üst resimdeki örneğimizin F8 hücresine aşağıdaki formülü yazıyoruz:

TÜRKÇE


=TOPLA.ÇARPIM(--(SIKLIK(KAÇINCI(B4:B13;B4:B13;0);SATIR(B4:B13)-SATIR(B4)+1)>0))

İNGİLİZCE


=SUMPRODUCT(--(FREQUENCY(MATCH(B4:B13;B4:B13;0);ROW(B4:B13)-ROW(B4)+1)>0)) Alternatif 2
Üst resimdeki örneğimizin F9 hücresine aşağıdaki formülü yazıyoruz:

TÜRKÇE


=TOPLA(EĞER(SIKLIK(EĞER(B4:B13<>"";KAÇINCI(B4:B13;B4:B13;0));SATIR(B4:B13)-SATIR(B4)+1);1))

İNGİLİZCE


=SUM(IF(FREQUENCY(IF(B4:B13<>"";MATCH(B4:B13;B4:B13;0));ROW(B4:B13)-ROW(B4)+1);1))
excel , excel dosya , excel depo , excel store , excel makro , excel vba , excel formül , excel function , excel fonsiyon, excel kaçıncı, excel match