Yıl Ay yaz, o dönemin tüm günlerini formül getirsin

Excel'de bir hücreye YIL (Year) bilgisini bir başka hücreye de AY (Month) bilgisini yazdığımızda, başka bir yerde yazdığımız dönemin tüm günlerine ait tarihleri yazsın isteyebiliriz.
Böyle bir durumda TARİH (Date) formüllerini kullanarak seçtiğimiz döneme ait tüm günleri ister alt alta, ister yan yana sıralayabiliriz. Örnek olarak; B3 hücresine 2017 B4 hücresine 5 yazalım.
B6 hücresine ise;
=EĞER(AY(TARİH($B$3;$B$4;SATIR(B1)))>$B$4;"";TARİH($B$3;$B$4;SATIR(B1))) (=IF(MONTH(DATE($B$3;$B$4;ROW(B1)))>$B$4;"";DATE($B$3;$B$4;ROW(B1)))) yazdığımızda ve formülü ister yana ister alta 31 satır/sütun kopyaladığımızda, 01.05.2017'den başlayıp 31.05.2017'ye kadar formüller ile günlerin sıralandığını görüyor olacaksınız.

Konuyla ilgili dosyamızın ekran görüntüsünü linkten izleyebilirsiniz.