Dizi Sabiti

Dizi Sabiti

Dizi sabiti, Excel formüllerinde sağlanan sabit kodlanmış bir değerler kümesidir. Dizi sabitleri küme parantezlerde {} şöyle görünür:

{"kırmızı"\"mavi"\"yeşil"}

Dizi sabitleri genellikle dizi formüllerinde tek bir değer yerine birden fazla değeri oluşturmak veya değiştirmek için kullanılır.

Örneğin, üst resimdeki BÜYÜK formülü, B3:B11 hücre aralığındaki ilk 3 değerin toplamını almak için aşağıdkai gibi bir dizi sabitiyle kullanılabilir:

=BÜYÜK(B3:B11;{1\2\3})

Çoğu durumda, dizi sabitlerini kullanan formüller, aslında dizi formülleri olmalarına rağmen Ctrl + Shift + Enter tuşlatına basmayı gerektirmez.

Birden çok sonuç

Bağımsız değişken olarak Excel formülüne sağlanan dizi sabiti neticesinde, bir dizide genellikle birden fazla sonuç alırsınız.

Üstteki örnekte, BÜYÜK formülü, TOPLA formülü tarafından en büyük 3 değeri döndürür ve bu 3 değerin toplamını sonuç olarak döndürür:

=TOPLA(BÜYÜK(B3:B11;{1\2\3}))



Dizi Sabiti Sınırlamaları

Bir dizi sabitini çevreleyen küme parantezler, Excel'in formül ayrıştırma mantığında "sabit" anlamına denk gelir.

Sonuç olarak, bir dizi sabitine başvuruları veya fomrüller ekleyemezsiniz. Bunu yaparsanız, dizi sabitini dizi değişkeni yapmış olursunuz.

Bu makale sonunda;

3 yerine 5, 5 yerine 10 içeriği toplamak istediğimde nasıl olacak, her seferinde tek tek formülü mü değiştirmem gerekecek?

diyenleri duyuyor gibiyim.
Bunun geleceğini düşünerek, Bir Aralıktaki X Küçük Değeri Toplamak ve Bir Aralıktaki X Büyük Değeri Toplamak Toplamak isimli iki dosyamızı sizler için hazırladık.

Dizi Sabiti Özelliğinin Kullanıldığı İçerikler

En Çok Tekrar Eden Metinleri Bulma (dosya)

Dizi Array Formülünun Analatiği (dosya)

Excel Dizi Formülleri (makale)

Excelde Dizi Formülü Nedir Nasıl Kullanılır (dosya)

Dizi Formülleri (dosya)

Üstteki alanda, Google Reklamları yerine sizin reklamınızın yayınlanmasını ister misiniz?
Reklam vermek istiyorum

Daha önce yorum yapılmamış!

Bir sayfanızda bulunan ya da aktarıldığında boş gelen hücrelere hep aynı değer girmeniz gereken hususlar olabilir.

Bu durumda;
  1. Sayfanızda arasında boşlukların bulunduğu veri aralığını seçin,
  2. Şerit Menü'den Giriş -> Bul ve Seç -> Git butonunu tıklayın.
  3. Ekrana gelen pencereden özel seçeneğini tıklayın.
  4. Yine ekrana gelen pencereden Boşluklar'ı seçin ve Tamam'a tıklayın.
  5. Tüm boşluklar seçili olarak gelecektir. Tüm boş hücreler seçiliyken, aktif boş hücreye ne istiyorsanız yazın ve Ctrl ve Enter tuşlarına birlikte basın.
Bu işlemin neticesinde, seçili alandaki tüm boşluklar artık yazdığınız değere ile doldurulmuş olacaktır.

Son olarak;
Sosyal Medya'da paylaşıp daha fazla kişinin bu ipucunu öğrenmesine vesile olup, sitemize de erişim için destek olun :)
Yükleniyor...