Dizi Sabiti


İnceleme Beğeni Favori Değerlendirme Ortalama Puan Yıldız Sayısı
175 0 0 0 0
Reklam Alanı
Türkiye'nin en popüler Excel Portalındaki içeriklerin en başında reklamınızın yayınlanmasını ister misiniz?
Reklam vermek istiyorum
Dizi Sabiti

Dizi sabiti, Excel formüllerinde sağlanan sabit kodlanmış bir değerler kümesidir. Dizi sabitleri küme parantezlerde {} şöyle görünür:

{"kırmızı"\"mavi"\"yeşil"}

Dizi sabitleri genellikle dizi formüllerinde tek bir değer yerine birden fazla değeri oluşturmak veya değiştirmek için kullanılır.

Örneğin, üst resimdeki BÜYÜK formülü, B3:B11 hücre aralığındaki ilk 3 değerin toplamını almak için aşağıdkai gibi bir dizi sabitiyle kullanılabilir:

=BÜYÜK(B3:B11;{1\2\3})

Çoğu durumda, dizi sabitlerini kullanan formüller, aslında dizi formülleri olmalarına rağmen Ctrl + Shift + Enter tuşlatına basmayı gerektirmez.

Birden çok sonuç

Bağımsız değişken olarak Excel formülüne sağlanan dizi sabiti neticesinde, bir dizide genellikle birden fazla sonuç alırsınız.

Üstteki örnekte, BÜYÜK formülü, TOPLA formülü tarafından en büyük 3 değeri döndürür ve bu 3 değerin toplamını sonuç olarak döndürür:

=TOPLA(BÜYÜK(B3:B11;{1\2\3}))



Dizi Sabiti Sınırlamaları

Bir dizi sabitini çevreleyen küme parantezler, Excel'in formül ayrıştırma mantığında "sabit" anlamına denk gelir.

Sonuç olarak, bir dizi sabitine başvuruları veya fomrüller ekleyemezsiniz. Bunu yaparsanız, dizi sabitini dizi değişkeni yapmış olursunuz.

Bu makale sonunda;

3 yerine 5, 5 yerine 10 içeriği toplamak istediğimde nasıl olacak, her seferinde tek tek formülü mü değiştirmem gerekecek?

diyenleri duyuyor gibiyim.
Bunun geleceğini düşünerek, Bir Aralıktaki X Küçük Değeri Toplamak ve Bir Aralıktaki X Büyük Değeri Toplamak Toplamak isimli iki dosyamızı sizler için hazırladık.
#Dizi Sabiti #Array constant
Dizi Sabiti Özelliğinin Kullanıldığı İçerikler İçeriğin Türü
Dizi Formülleri dosya
Dizi Array Formülünun Analatiği dosya
En Çok Tekrar Eden Metinleri Bulma dosya
Excelde Dizi Formülü Nedir Nasıl Kullanılır dosya

Daha önce yorum yapılmamış!

YARARLI KISAYOLLAR
Yardım F1
Hücreyi Taşıma Sürükle
Bir önceki sonucu bulma Ctrl Shift F4
Bitişik Hücre Aralığı Seçme Shift Tıklama
Farklı Kaydetme F12
Excel'de, 1000 şeklinde görünen bir rakamı 1.000,00 şeklinde kolayca getirmek için, rakamların olduğu alanı seçtikten sonra klavyedeki;
Ctrl + Shift + 1 tuşlarına birlikte basmanız yeterli olacaktır.
Yükleniyor...