Dizi

Excelde Diziler isimli bu yazımız Diziler hakkında bilgi vermek ve referans olarak kullanmak amacıyla hazırlanmıştır.

Diziler, bir elektronik tablodaki aralıklarla mükemmel bir şekilde eşlenebilir, bu nedenle Excel'de çok önemli bir yere sahiptirler. Çalışma sayfasındaki herhangi bir hücre ya da hücre aralığı başvurusu kullanan tüm Excel formülleri, dizilerle çalışmaktadır.

image-20200409165404-1.png

Üstte gösterilen örnekte, üç farklı dizi formül kullanımında şöyle sıralanır:

B3:D3 // 1 x 3 dizi
B6:D6 // 3 x 1 dizi
D9:D10 // 2 x 3 dizi

Dizilerin aynı sütun ve satırlarda olması şarttır. Bir kare ya da dikdörtgen gibi düşünülebilir. Bunun dışında farklı farklı ve birbirine komşu olmayan hücreler dizi olarak atanamaz.

Dizi Sözdizimi

Excel'deki tüm diziler küme parantezleri {} içinde yazılır ve dizi öğeleri arasındaki özel işaretler, diziye alınmış öğelerin yatay mı dikey mi olduğunu belirler.
Türkçe'ye uyumlu olan Excel versiyonlarında yatay diziler için noktalı virgül (;), dikey diziler için ise ters taksim (\) karakteri kullanılır.
Örneğin, aşağıdaki her iki dizi de 1-3 sayısını içerir ama biri yatay, biri dikey dizidir.

{1;2;3} // yatay dizi
{1\2\3} // dikey dizi

Metin içeren ifadeler diziye alınırken, mutlaka başlarına ve sonlarına çift tırnak (") karakteri eklenmelidir.

{"a";"b";"c"}

Belirtildiği gibi diziler bir hücre ya da hücre aralığındaki değerlerle kolayca eşleştirilebilirler.
En üstteki resmimizde gösterilen örnekteki aralıklar aşağıdaki gibi dizilerdir:

B3:D3 = {"Sarı";"Lacivert";"Yeşil"}
B5:B7 = {"Sarı"\"Lacivert"\"Yeşil"}
B9:D10 = {1;2;3\4;5;6}

Formüllerde Diziler

Diziler doğrudan aralıkları eşlediğinden, formül yapısının bir dizi ile uyumlu olduğu her durumda tüm formüller ile uyumlu bir şekilde çalışırlar.
Basit bir örnek için TOPLA fonksiyonunu kullanalım.
A1:A5 aralığında 15,30,45,60,75 şeklinde verilerin yazılı olduğunu varsayalım. TOPLA fonksiyonu bu aralıkta bulunan değerleri toplamak için oluşturacağımız formülün başrol oyuncusudur. Formül oluştuğunda, TOPLA fonsiyonu A1:A5 aralığındaki değerlerin yer aldığı diziye başvurur. Bu fonksiyonun kurgulanış yapısıdır ve aralıktaki sayısal veriler toplayarak 225 sonucunu verir.

=TOPLA(A1:A5)
=TOPLA({15\30\45\60\75})
=225 // Üstteki her iki formülde 225 sonucunu verir

Not: F9 tuşunu, Excel formüllerinizde sonuçları görmek için kullanılmaktadır.

Dizi Formülleri

Dizi formülleri, bir dizi sonuç sunan bir işlemi içerir.
Aşağıdaki örnek formül, aslında A1:A5 aralığındaki yazılı olan verilerin toplam kaç karakterden oluştuğunu gösteren basit bir dizi formülüdür:

=TOPLA(UZUNLUK(A1:A5))

UZUNLUK fonksiyonunun içinde A1:A5 bir değerler dizisine döndürülür. UZUNLUK fonksiyonu daha sonra her değer için bir karakter sayımı üretir ve 5 sonuçtan oluşan bir dizi döndürür. TOPLA fonksiyonu ise bu dizi içinde 1 kez sayılmış tüm öğelerin toplamını verir.

Formülün sonucu doğru vermesi için Ctrl + Shift + Enter tuşlarına basmamız gerektiğini de hatırlatmak isterim.

Excelde Diziler isimli referans amaçlı hazırladığımız bu yazımızda, Excel'de Dizi içeriği hakkında bilgi vermeye, kullanımın kolayca anlaşılmasını sağlamayı amaçladık.
Yararlı olmasını temenni ederiz.

Etiketler

Excel Eğitimleri

Dizi Özelliğinin Kullanıldığı İçerikler

İçerir Kelime Filtreleme (dosya)

Formülle Netten Brüte Maaş Hesaplama (program)

Eğitim ve Organizasyon Katılımcılarını Gruplandırma (dosya)

Dizi Formülü ile Toplama (dosya)

Brütten Nete Maaş Hesaplama (program)

Sıfırdan Sonraki İlk Sayıyı Bulma (dosya)

2021 Yılı Gelir Vergisi Dilimleri (dosya)

Tarih Zaman Formülleri (dosya)

En Çok Tekrar Eden Sayıları ve Adetlerini Bulma (dosya)

Karışık Verileri Ada Göre Sıralama (dosya)

Dinamik Dizi Formülleri ve Yeni Nesil Excel (kurs)

Dizi Nedir (video)

Dizi Formülleri (dosya)

Farklı Sayfadaki Değerlere Göre Koşullu Biçimlendirme (dosya)

Personel Durum Çizelgesi (program)

Excelde Küme İşlemleri (dosya)

Kasa Defteri Takibi (dosya)

Haftanın Günlerinin Sayısal Karşılıklarını Bulma (sorular)

UserForm Üzerinde Resim Gösterme Örneği (dosya)

Dizi Formüllerinde Boolean İşlemleri (video)

Maaş Hesaplama V1 (program)

Boolean Değerlerinin Sayıya Dönüştürülmesi (video)

Excel Hazır Takvim (dosya)

Birden Fazla Kritere Göre Tarih Bulma (dosya)

Hesaplamalarda Minimum Maksimum (dosya)

Dizi Array Formülünun Analatiği (dosya)

Excel Dizi Formülleri (makale)

Formülle Maaş Hesaplama - 2019 (program)

Excelde Dizi Formülü Nedir Nasıl Kullanılır (dosya)

Üstteki alanda, Google Reklamları yerine sizin reklamınızın yayınlanmasını ister misiniz?
Reklam vermek istiyorum

Daha önce yorum yapılmamış!

Klavyeyi kullanarak hızlı bir şekilde tablolarınıza satır eklemek için, satır eklemek istediğiniz hücreye gelip sırayla Alt, E ve S tuşlarına basmanız yeterli olacaktır.

Birden fazla satır eklemek isterseniz, aralıksız olarak seçim için Shit, aralıklı olarak seçin için Ctrl tuşları ile, aralara ekleme yapılacak satırları seçtikten sonra yine, sırayla Alt, E ve S tuşlarına basmanız yeterli olacaktır.

Benzer şekillerde sütun eklemek için sırayla Alt, E ve T tuşlarına basmanız yeterli olacaktır.

Bu kısayollar Türkçe Excel kullanıcıları için geçerlidir.
Yükleniyor...