Dizi


İnceleme Beğeni Favori Değerlendirme Ortalama Puan Yıldız Sayısı
267 0 0 0 0
Reklam Alanı
Türkiye'nin en popüler Excel Portalındaki içeriklerin en başında reklamınızın yayınlanmasını ister misiniz?
Reklam vermek istiyorum
Excelde Diziler isimli bu yazımız Diziler hakkında bilgi vermek ve referans olarak kullanmak amacıyla hazırlanmıştır.

Diziler, bir elektronik tablodaki aralıklarla mükemmel bir şekilde eşlenebilir, bu nedenle Excel'de çok önemli bir yere sahiptirler. Çalışma sayfasındaki herhangi bir hücre ya da hücre aralığı başvurusu kullanan tüm Excel formülleri, dizilerle çalışmaktadır.

image-20200409165404-1.png

Üstte gösterilen örnekte, üç farklı dizi formül kullanımında şöyle sıralanır:

B3:D3 // 1 x 3 dizi
B6:D6 // 3 x 1 dizi
D9:D10 // 2 x 3 dizi

Dizilerin aynı sütun ve satırlarda olması şarttır. Bir kare ya da dikdörtgen gibi düşünülebilir. Bunun dışında farklı farklı ve birbirine komşu olmayan hücreler dizi olarak atanamaz.

Dizi Sözdizimi

Excel'deki tüm diziler küme parantezleri {} içinde yazılır ve dizi öğeleri arasındaki özel işaretler, diziye alınmış öğelerin yatay mı dikey mi olduğunu belirler.
Türkçe'ye uyumlu olan Excel versiyonlarında yatay diziler için noktalı virgül (;), dikey diziler için ise ters taksim (\) karakteri kullanılır.
Örneğin, aşağıdaki her iki dizi de 1-3 sayısını içerir ama biri yatay, biri dikey dizidir.

{1;2;3} // yatay dizi
{1\2\3} // dikey dizi

Metin içeren ifadeler diziye alınırken, mutlaka başlarına ve sonlarına çift tırnak (") karakteri eklenmelidir.

{"a";"b";"c"}

Belirtildiği gibi diziler bir hücre ya da hücre aralığındaki değerlerle kolayca eşleştirilebilirler.
En üstteki resmimizde gösterilen örnekteki aralıklar aşağıdaki gibi dizilerdir:

B3:D3 = {"Sarı";"Lacivert";"Yeşil"}
B5:B7 = {"Sarı"\"Lacivert"\"Yeşil"}
B9:D10 = {1;2;3\4;5;6}

Formüllerde Diziler

Diziler doğrudan aralıkları eşlediğinden, formül yapısının bir dizi ile uyumlu olduğu her durumda tüm formüller ile uyumlu bir şekilde çalışırlar.
Basit bir örnek için TOPLA fonksiyonunu kullanalım.
A1:A5 aralığında 15,30,45,60,75 şeklinde verilerin yazılı olduğunu varsayalım. TOPLA fonksiyonu bu aralıkta bulunan değerleri toplamak için oluşturacağımız formülün başrol oyuncusudur. Formül oluştuğunda, TOPLA fonsiyonu A1:A5 aralığındaki değerlerin yer aldığı diziye başvurur. Bu fonksiyonun kurgulanış yapısıdır ve aralıktaki sayısal veriler toplayarak 225 sonucunu verir.

=TOPLA(A1:A5)
=TOPLA({15\30\45\60\75})
=225 // Üstteki her iki formülde 225 sonucunu verir

Not: F9 tuşunu, Excel formüllerinizde sonuçları görmek için kullanılmaktadır.

Dizi Formülleri

Dizi formülleri, bir dizi sonuç sunan bir işlemi içerir.
Aşağıdaki örnek formül, aslında A1:A5 aralığındaki yazılı olan verilerin toplam kaç karakterden oluştuğunu gösteren basit bir dizi formülüdür:

=TOPLA(UZUNLUK(A1:A5))

UZUNLUK fonksiyonunun içinde A1:A5 bir değerler dizisine döndürülür. UZUNLUK fonksiyonu daha sonra her değer için bir karakter sayımı üretir ve 5 sonuçtan oluşan bir dizi döndürür. TOPLA fonksiyonu ise bu dizi içinde 1 kez sayılmış tüm öğelerin toplamını verir.

Formülün sonucu doğru vermesi için Ctrl + Shift + Enter tuşlarına basmamız gerektiğini de hatırlatmak isterim.

Excelde Diziler isimli referans amaçlı hazırladığımız bu yazımızda, Excel'de Dizi içeriği hakkında bilgi vermeye, kullanımın kolayca anlaşılmasını sağlamayı amaçladık.
Yararlı olmasını temenni ederiz.

Daha önce yorum yapılmamış!

Bir UserForm üzerinde, sadece sonundaki numarası değişen nesneleriniz varsa, bu nesneleriniz için hızlı bir şekilde silme, gizleme, gösterme gibi işlemler yapmak istiyorsanız, Control kodunu kullanabilirsiniz.

Örneğin: UserForm üzerinde 50 TextBox nesnesi var ve siz tek bir seferde bu TextBox nesnelerini gizlemek istiyorsunuz. Bunun en kısa yöntemi için aşağıdaki kodu kullanabilirsiniz.

For i = 1 To 50
Controls("TextBox" & i).Visible = False
Next int1

Faydalı olması temennisiyle
Bu Özellik Kullanılarak Hazırlanmış İçerikler
İçerik Adı Ekleyen Tarih Tür
Personel Durum Çizelgesi Omer_BARAN 11 Eylül 2020 dosya
En Çok Tekrar Eden Sayıları ve Adetlerini Bulma admin 27 Haziran 2020 dosya
Yükleniyor...