Dinamik Dizi Davranışları


İnceleme Beğeni Favori Değerlendirme Ortalama Puan Yıldız Sayısı
317 1 1 0 0
Reklam Alanı
Türkiye'nin en popüler Excel Portalındaki içeriklerin en başında reklamınızın yayınlanmasını ister misiniz?
Reklam vermek istiyorum
Yeni dinamik dizi formülleri çok fazla ilgi görecek olsa da, dinamik dizi davranışının nasıl entegre olduğunu anlamak önemlidir. Excel'in 365 sürümünde tüm formüller artık yeni bir hesaplama mantığıyla çalışmaktadırlar. Bu, bir formül birden çok sonuç döndürdüğünde, bu sonuçların çalışma sayfasındaki birden çok hücreye taşacağı anlamına gelir. Aynı zamanda bu, dinamik dizilerle çalışmak üzere orijinal olarak tasarlanmamış, yani Excel'in 365 sürümü dışındaki diğer versiyonlarındaki daha eski formülleri de içerir.

Örneğin, UZUNLUK formülü bir hücredeki karakter sayısını döndürür. Geleneksel Excel'de her seferinde bir hücre için kullanmanız gerekir.

Dinamik Excel'de UZUNLUK formülüne bir değer aralığı verirsek, birden çok sonuç elde edebiliriz. Başka aracı formüllere gerek kalmadan ve özel bir sözdizimi olmadan aralıktaki tüm karakterlerin uzunluğunun toplamını almak için TOPLA formülünü rahatça kullanabiliriz.

=TOPLA(UZUNLUK(B3:B8))

TOPLA Formülü Kullanımı

Üstteki ekran görüntüsünü inceleyenler için bu, her türlü formülü etkileyebilecek büyük bir değişikliktir.

Örneğin, DÜŞEYARA formülü, bir sütun dizini kullanarak bir tablodan tek bir değer almak üzere tasarlanmıştır.

=DÜŞEYARA(B2;B5:D8;2;0)

DÜŞEYARA Kullanımı

Üstteki formül ile Mahir isimli öğrencinin ikinci sıraki sınıfını bulmuş olduk.

Bununla birlikte, dinamik dizilerde, böyle bir dizi sabiti kullanarak DÜŞEYARA formülünden birden fazla değer bulmasını isteyebiliriz.

=DÜŞEYARA(B2;B7:D10;{1;2;3};0)

Dinamik Dizi ile DÜŞEYARA Kullanımı

Sınıf ve Numaralarıda tek bir formülde arayabiliriz.

Başka bir deyişle, DÜŞEYARA asla birden fazla değer döndürmek için tasarlanmamış olsa da, şimdi yeni dinamik dizi formül motoru sayesinde artık bunu yapabilir.

Dinanik diziler kullanılarak oluşturulmuş olan Yeni Nesil Düşeyara isimli dosyamızı hemen indirip, nasıl işlediğini görebilirsiniz.

Bu işlemin yalnızca Excel 365 kullanıcıları için geçerli olduğunu unutmamalıyız.

Bir örnek daha inceleyelim.

Bu çalışma sayfasında amaç, adın ilk karakterini soyadıyla birleştirerek kullanıcı adları oluşturmaktır.

Dinamik dizilerle, tam aralıkları kullanabilir ve formülü tek adımda girebilirim.

=SOLDAN(B3:B12)&C3:C12

Dinamik Dizi SOLDAN Kullanımı

Excel, taşma aralığındaki tüm sonuçları döndürdü.

Bu formülün değiştirilmesi de kolaydır. Örneğin kullanıcı adlarını KÜÇÜKHARF formülüyle küçük harfle yazmak istersek, yalnızca orijinal formülü tek bir yerde düzenlemek yeterli olacaktır.

=KÜÇÜKHARF(SOLDAN(B3:B12)&C3:C12)

KÜÇÜKHARF Dinamik Dizi Kullanımı

Enter tuşuna basmanız, tüm sonuçların güncellenmesi için yeterli olacaktır.

Her zaman olduğu gibi, üstteki tüm sonuçlar dinamiktir.

Bir adı değiştirir değiştirmez anında yeni bir sonuç alırız.
BU MAKALEDE KULLANILAN EXCEL ÖZELLİKLERİ:
SOLDAN - UZUNLUK - KÜÇÜKHARF - TOPLA - DÜŞEYARA - Dinamik Dizi - Taşma Aralığı - Dinamik Excel

Daha önce yorum yapılmamış!

Bir Excel hücresinde bulunan veriyi başka bir hücre ile kolayca yer değiştirmek için; Shift tuşuna basılı tutarak hücrenin alt kısmından üste ya da alta sürüklemeniz yeterli olacaktır.

Hızlı Yer Değiştirme
İLGİ ÇEKİCİ İÇERİKLER
İçerik Adı Ekleyen Tarih Tür
Son İki Değer Hariç Sondan İkinci ve Üçüncü Değerin Ortalaması admin 22 Eylül 2019 dosya
Proforma Fatura Örneği admin 14 Aralık 2019 dosya
Makro ile Seçilen Klasörün Yolunu Öğrenme Feyzullah 09 Ekim 2019 dosya
Rastgele Grup Atama lordkisame 21 Nisan 2020 sorular
Excel Yinelenenleri Kaldır admin 26 Ağustos 2020 dosya
Yükleniyor...