Dinamik Alan Tanımlama

Bu yazımızda, ad tanımlaması yaptığınız bir aralığa, yeni bir veri eklendiğinde otomatik olarak tanımlanmış aralığı nasıl genişletebilirsinizi anlatacağız..

1. Örneğin, A1:A4 aralığını seçin ve ExcelDepo olarak adlandırın.

2. C1 hücresine =TOPLA(ExcelDepo) şeklinde formülünüzü yazın.

dat1
3. A5 hücresine herhangi bir değer eklediğinizde, C1 hücresindeki toplamın değişmediğini göreceksiniz. Çünkü A5 hücresi, ExcelDepo aralığının dışında kalmaktadır.

dat2
Eğer tanımladığınız aralığın yeni bir veri eklendiğinde otomatik olarak tanımladığınız ad verisine eklenmesini istiyorsunuz aşağıdaki adımları izleyin.

4. Formüller sekmesinde, Tanımlanmış Adlar grubunda, Ad Yöneticisi'ni tıklayın.

at8
5. Düzenle'yi tıklayın.

dat3
6. "Başvuru yeri" kutusuna tıklayın ve aşağıdaki formülü girin
=KAYDIR($A$1;0;0;BAĞ_DEĞ_DOLU_SAY($A:$A);1)

dat4
Açıklama: KAÇINCI formülü 5 argüman alır.
Başv: $A$1,
Satırlar: 0,
Sütunlar: 0,
Yükseklik: BAĞ_DEĞ_DOLU_SAY($A:$A),
Genişlik: 1 şeklinde.
BAĞ_DEĞ_DOLU_SAY($A:$A) A sütunundaki değerlerin sayısını sayar.
Bu formülü kullandıktan sonra, A sütunununa yeni bir değer eklediğinizde, BAĞ_DEĞ_DOLU_SAY($A:$A) sürekli artar ve sonuç olarak adlandırılmış ExcelDepo aralığı genişler.

7. Tamam ve Kapat'ı tıklatın.

8. Şimdi, C3 hücresinin otomatik olarak toplamı güncelleştirdiğini test edin.

dat5
dat6
BU MAKALEDE KULLANILAN EXCEL ÖZELLİKLERİ:
#Dinamik Alan Tanımlama
Üstteki alanda, Google Reklamları yerine sizin reklamınızın yayınlanmasını ister misiniz?
Reklam vermek istiyorum

Daha önce yorum yapılmamış!

Eğer aynı değeri birden fazla hücreye aşağıya doğru kopyalamak isterseniz, Ctrl + D tuşlarını kullanabilirsiniz. Örneğin A2 hücresinde X ürünü yazın ve A2:A10 aralığını seçtikten sonra Ctrl + D tuşuna bastığınız zaman A2:A10 aralığının A2'deki değer ile dolduğunu görürsünüz.
Yükleniyor...