Çift Tire


İnceleme Beğeni Favori Değerlendirme Ortalama Puan Yıldız Sayısı
324 0 0 0 0
Reklam Alanı
Türkiye'nin en popüler Excel Portalındaki içeriklerin en başında reklamınızın yayınlanmasını ister misiniz?
Reklam vermek istiyorum
Excel'de Çift Tire Ne İşe Yarar?

Çift tire, DOĞRU YANLIŞ sonuçlarını döndüren ve özellikle dizi içeren formüllerde,DOĞRU değerini 1'e, YANLIŞ değerini 0'a döndürmek için kullanılan bir işlemdir.

Örneğin, yukarıdaki resimde her biri beş değer içeren iki grup gösterilmektedir. Bu iki grupta yer alan üç değer eşleşir ve iki değer farklıdır. Eşleşen değerleri saymak için kullanılan formül:

=TOPLA.ÇARPIM(--(B5:B9=C5:C9))

Formülü incelediğimizde, B5:B9 ve C5:C9 aralıklarının karşılaştırılması yapılmaktadır ve aslında sonuç şu şekildedir:

=TOPLA.ÇARPIM(--{DOĞRU\DOĞRU\YANLIŞ\DOĞRU\YANLIŞ})

Birbiri ile eşleşen değerleri (DOĞRU sonucunda olanları) saymak istiyoruz, ama kullandığımız ancak TOPLA.ÇARPIM formülü işlem yapmak için sayısal değerler aramaktadır. Yani formül sayısal olmayan değerleri yok sayar.

Bu nedenle DOĞRU ve YANLIŞ değerlerini 1 ve 0 olarak değiştirmek için bir çift tire kullanırız.

Bu, Excel'in matematik işlemleri sırasında otomatik olarak DOĞRU / YANLIŞ 1/0 değerine zorlaması nedeniyle çalışır. İlk negatif DOĞRU değerleri -1 olarak ve YANLIŞ değerleri 0 olarak değiştirir. İkinci negatif -1'i 1 olarak değiştirir. TOPLA.ÇARPIM içindeki sonuç şöyle görünür:

=TOPLA.ÇARPIM({1\1\0\1\0})

TOPLA.ÇARPIM formülü de, bir dizi tüm öğelerin toplamını döndürür ve bize 3 sonucunu verir.

Daha önce yorum yapılmamış!

Excel'in MUTLAK fonksiyonunu kullanarak, bir negatif sayıyı kolayca pozitif hale getirebileceğinizi biliyor muydunuz?
A2 hücresinde -525,52 şeklinde bir değer olduğunu varsayalım.
B2 hücresine, =MUTLAK(A2) yazdığınızda, sonucun 525,52 şekline döneceğini göreceksiniz.

Not: Pozitif olan rakamlar aynen korunur.

Eğer bir aralıkta yer alan ve birden fazla negatif sayıyı, tek seferde ve bir kereye mahsus pozitif değere sayıya dönüştürmek isterseniz:
  1. Boş bir hücreye -1 yazın ve -1 sayısının yer aldığı hücreyi kopyalayın.
  2. Dönüştürmek istediğiniz negatif sayıları fareniz ile seçin.
  3. özel Yapıştır -> Değerler -> çarp deyin.
Tüm negatif sayıların pozitif sayıya döndüğünü göreceksiniz.
Yükleniyor...