Misafir Kullanıcı 14 Ağustos 2021 352

Aynı İsimden Kaç Tane Var Nasıl Bulurum

İşyerimizdeki çalışanlarımız arasında, aynı isme sahip olanların ve en çok hangi isim varsa bunun bulunarak, kaç çalışanın bu isimli olduğunu saymak istiyorum.

Örneğin çalışanlarımızın isimlerini listeledik ve Ahmet en çok verilen isim çıktı diyelim. Hem Ahmet sonucunu hem de Ahmet adının kaç çalışanda olduğunu bulmak istiyorum yani. Umarım anlatabilmişimdir.

Yardımlarınızı rica ederim.
EXCEL DEPO 4 ay önce

Bu soru kapsamında kıymetli yöneticimiz 52779 tarafından hazırlanan dosyaya, buradan erişebilirsiniz.

52779 4 ay önce

İsimlerin A2'den itibaren olduğunu varsayarsak;

  1. B2 hücresine:
    =EĞERHATA(İNDİS($A$2:$A$1001;ENÇOK_OLAN(EĞER(($A$2:$A$1001<>"")
    *
    (EĞERSAY($A$1:A1;$A$2:$A$1001)=0);
    KAÇINCI($A$2:$A$1001&"";$A$2:$A$1001&"";0))));"")
  2. B3 hücresine:
    =EĞER(B2="";"";EĞERSAY($A$2:$A$1001BI2))
yazmanız yeterli olacaktır. Konuyla ilgili olarak kapsamlı bir dosya en kısa sürede eklenecektir.

Ben 1000 satırlık bir fake isim listesi oluşturarak denediğim için, A2:A1001 aralığını kullandım. Bu alanı da kendi çalışan listenize göre revize edersiniz.

Umarım bu formüller şimdilik işinizi görür.

De** Du**** 4 ay önce

Üzerinde biraz durayım dedim ama konu beni aştı. Bir cevap gelecekse, ben de merak ediyorum çözümünü.

Sanki çözümü soru kadar kolay değil, muhtemelen oldukça kapsamlı bir çalışma ile çözülebilir.


EXCEL DEPO Admin 4 ay önce

Kesinlikle, dediğiniz gibi söylem olarak kolay ama formülasyon kısmı için aynı kolaylıktan bahsedemeyiz.

İlk fırsatta cevaplayıp, indirilebilir halini de Dosyalar kısmımıza ekleyeceğiz. Hatta kalınız :)

Excel hücrelerinizde, ok tuşlarının dışında;

  • Enter tuşu ile alt hücreye,
  • Shift + Enter tuşları ile üst hücreye
  • Tab ile sağ hücreye,
  • Shift + Tab tuşları ile sol hücreye
gidebilirsiniz.

Backlink Reklam Bu alanda 50 karakterlik açıklama ile web sitenize ait Backlink Reklam yayınlayabilirsiniz.

Yükleniyor...